Bug 16307 - Bug in installation scripts
Bug in installation scripts
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-15 22:33 EDT by gregory.hosler
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 23:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gregory.hosler 2000-08-15 22:33:59 EDT
If you fill up the install dialog panels, and get to th epoint that you are
ready to install, and then decide to <BACK> thru some of the panels
maybe to check some settings, or reset a setting, and then <NEXT>
thru the panels, there are 2 issues:

1) certain panels clear the settings as you re-enter them ("next"ing into
them)
    This is inconvenient. It would be nice if they remembered the old
settings.

    Specifically, the disk druid panel. if you set your mount points, and
then
    back up to the fdisk, when you next into disk druid, you have to
re-enter
    the mount points.

2) certain panels appear to remember the settings, but in actual fact, the
remembered
    settings are not passed onto the installation, and once you boot the
installed
    system, you find, way too late, that the settings are dropped.

    Speficically:

	timezone setting

	network setting (ip settings) 

    to see what I am talking about, set these to non-default values, next
forward to the
    "about to install page", then <PREV> back top the disk druid page, then
<NEXT>
    forward. You will see your timezone selected, and your IP info as you
entered.
    then do the install. then boot up. wrong timezone (i think it is the
default one),
    and some or all of your IP settings are not set.

I don't think it is so uncommon to BACK thru the install panel, for example
to confirm
settings. it can also happen for legit reasons. for example, install tells
you that "/" is
to small, to you "BACK" to disk druid, reassign the "/" partition to a
larger one, or whatever,
and <NEXT> thru to the install. The install will have bad timezone, and teh
network will
not be properly setup.

-Greg
Comment 1 Michael Fulbright 2000-10-09 16:03:56 EDT
Please verify this Brent.
Comment 2 Brent Fox 2000-10-16 14:57:25 EDT
Addressing issue number one, the installer will remember your changes in certain
situations.  For example, imagine that I enter the mount point screen, set my
mount points, and click "Next" to go to the next screen.  Now, if I click "Back
two or three times and eventually click "Next" a number of times so that I
re-enter the mount point screen, my changes will be remembered.  This is because
clicking "Next" at the mount point screen causes the changes to be remembered,
but if you click "Back" first, the changes will not be remembered.  
This is not the behavior that the user expects.  This bug will be added to our
list for the next release.
Issue number two is related but different.  I will look at it soon.
Comment 3 Brent Fox 2000-10-30 23:47:34 EST
I was not able to reproduce bug related to second issue.  In fact, I tested this
and it seems to be working correctly.  As for the first issue, the changes take
effect when 'Next' is pressed.  The reason that the changes do not take effect
on clicking 'Back' is because 'Back' is meant to provide the user a way to back
out of the screen without any committing to any changes.  I'm resolving as not a
bug.

Note You need to log in before you can comment on or make changes to this bug.