Bug 1631068 - swrast: hardware cursor not used, log spammed with "Window manager warning: HW cursor for format 875713089 not supported" messages
Summary: swrast: hardware cursor not used, log spammed with "Window manager warning: H...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 29
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F29BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-09-19 20:18 UTC by Adam Williamson
Modified: 2018-09-27 16:40 UTC (History)
16 users (show)

Fixed In Version: mesa-18.2.0-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-20 22:36:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1577109 None None None 2019-06-11 13:59:14 UTC

Internal Links: 1577109

Description Adam Williamson 2018-09-19 20:18:29 UTC
If you boot a current Fedora 29 Workstation live image in a typical Boxes or virt-manager VM, you'll likely see this. The cursor in the VM will be kind of laggy, and the journal will be full of messages like this:

Sep 19 15:09:17 localhost-live org.gnome.Shell.desktop[3490]: Window manager warning: HW cursor for format 875713089 not supported

it seems this is caused by a mesa bug:

https://bugs.freedesktop.org/show_bug.cgi?id=104926

that will happen whenever swrast is used (so, in VMs without passthru 3D acceleration is an obvious case).

We have a fix for this building at present, but I wanted to file a bug to propose it as a Beta freeze exception. Both the lagginess and the log spam are annoying, and an update would not fix the problem when booting the Beta live or on first boot after install.

Comment 1 Mohan Boddu 2018-09-19 20:21:43 UTC
+1 FE

Comment 2 Fedora Update System 2018-09-19 20:26:36 UTC
mesa-18.2.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b94fe152c1

Comment 3 Paul Whalen 2018-09-19 20:36:30 UTC
+1 FE

Comment 4 Kevin Fenzi 2018-09-19 20:38:16 UTC
+1 FE

Comment 5 Adam Williamson 2018-09-19 20:49:01 UTC
That's +3, setting accepted.

Comment 6 Fedora Update System 2018-09-20 16:19:02 UTC
mesa-18.2.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b94fe152c1

Comment 7 Fedora Update System 2018-09-20 22:36:30 UTC
mesa-18.2.0-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Kamil Páral 2018-09-25 10:10:47 UTC
This has been marked as "pushed stable", but hasn't appeared in any composes, I filed a releng ticket about it:
https://pagure.io/releng/issue/7836


Note You need to log in before you can comment on or make changes to this bug.