Bug 1631217 - unable to install stratis
Summary: unable to install stratis
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 1615770
TreeView+ depends on / blocked
 
Reported: 2018-09-20 08:55 UTC by lnie
Modified: 2018-10-22 16:13 UTC (History)
9 users (show)

Fixed In Version: dnf-4.0.4-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-22 16:13:17 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description lnie 2018-09-20 08:55:14 UTC
Description of problem:

[root@localhost-live lnie]# dnf module install stratis 
Last metadata expiration check: 0:22:15 ago on Thu 20 Sep 2018 04:26:49 PM CST.
Unable to resolve argument stratis
No match for package stratis-cli
Error: No match for one or more arguments

Version-Release number of selected component (if applicable):
dnf-3.5.1-1.fc29.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Daniel Mach 2018-09-24 11:31:06 UTC
There's no stratis-cli in the artifacts of the stratis module.
The behavior is expected.

Comment 2 Igor Gnatenko 2018-09-24 12:35:02 UTC
(In reply to Daniel Mach from comment #1)
> There's no stratis-cli in the artifacts of the stratis module.
> The behavior is expected.

modules are allowed to depend on package from different modules (in this case: platform).

Comment 3 Igor Gnatenko 2018-09-29 08:14:33 UTC
Any news here?

Comment 4 Jaroslav Mracek 2018-10-01 13:36:40 UTC
Please can you upgrade to dnf-3.6.1 from our copr repository (dnf copr enable rpmsoftwaremanagement/dnf-nightly) and provide --debugsolver data> The 3.6.1 provides advance debug information.

Comment 5 Igor Gnatenko 2018-10-01 14:28:33 UTC
(In reply to Jaroslav Mracek from comment #4)
> Please can you upgrade to dnf-3.6.1 from our copr repository (dnf copr
> enable rpmsoftwaremanagement/dnf-nightly) and provide --debugsolver data>
> The 3.6.1 provides advance debug information.

You know that you can test it yourself, right?

[root@e082b19cdd59 /]# dnf module install stratis
Last metadata expiration check: 0:41:35 ago on Mon 01 Oct 2018 01:43:02 PM UTC.
No default profiles for module stratis:1
Unable to resolve argument stratis
No match for package stratis-cli
Error: Problems in request:
broken groups or modules: stratis
[root@e082b19cdd59 /]# dnf module install stratis/default
Last metadata expiration check: 0:41:46 ago on Mon 01 Oct 2018 01:43:02 PM UTC.
Unable to resolve argument stratis/default
No match for package stratis-cli
Error: Problems in request:
broken groups or modules: stratis/default

And obviously there is nothing in debugdata because that contains only information about modules (not the rest of RPMs).

Comment 6 Jaroslav Mracek 2018-10-01 14:46:44 UTC
I am really sorry, I have Fedora 28 and I cannot reproduce the issue. Please can you provide requested data. Thanks a lot.

Comment 7 Petr Šabata 2018-10-01 14:49:48 UTC
I think the issue is that DNF searches for profile packages only in the module's own artifacts; at least I've seen this elsewhere.

This only started happening "recently"; it still works fine in dnf-2.7.5-12.fc28.noarch.

Comment 8 Jaroslav Mracek 2018-10-01 15:19:42 UTC
Ok, I have old metadata in my virtual F29, therefore I was unable to reproduce the bug.

Comment 9 Jaroslav Mracek 2018-10-01 15:47:56 UTC
I created a patch that should fix the issue (https://github.com/rpm-software-management/dnf/pull/1228)

Comment 10 Fedora Update System 2018-10-15 12:28:52 UTC
dnf-plugins-core-4.0.0-1.fc29 dnf-4.0.4-1.fc29 libdnf-0.22.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2789f6b6e7

Comment 11 Fedora Update System 2018-10-15 18:23:25 UTC
dnf-4.0.4-1.fc29, dnf-plugins-core-4.0.0-1.fc29, libdnf-0.22.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2789f6b6e7

Comment 12 Fedora Update System 2018-10-17 13:01:54 UTC
dnf-4.0.4-1.fc29 dnf-plugins-core-4.0.0-2.fc29 libdnf-0.22.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2789f6b6e7

Comment 13 Fedora Update System 2018-10-17 23:30:49 UTC
dnf-4.0.4-1.fc29, dnf-plugins-core-4.0.0-2.fc29, libdnf-0.22.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2789f6b6e7

Comment 14 Fedora Update System 2018-10-18 14:06:42 UTC
anaconda-29.24.6-1.fc29 dnf-4.0.4-1.fc29 dnf-plugins-core-4.0.0-2.fc29 libblockdev-2.20-2.fc29 libdnf-0.22.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2789f6b6e7

Comment 15 Fedora Update System 2018-10-20 19:22:20 UTC
anaconda-29.24.7-1.fc29, dnf-4.0.4-1.fc29, dnf-plugins-core-4.0.0-2.fc29, libblockdev-2.20-2.fc29, libdnf-0.22.0-5.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2789f6b6e7

Comment 16 Fedora Update System 2018-10-22 16:13:17 UTC
anaconda-29.24.7-1.fc29, dnf-4.0.4-1.fc29, dnf-plugins-core-4.0.0-2.fc29, libblockdev-2.20-2.fc29, libdnf-0.22.0-5.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.