Bug 1631360 - use "Red Hat" manufacturer in SMBIOS for RHV VMs
Summary: use "Red Hat" manufacturer in SMBIOS for RHV VMs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: Arik
QA Contact: Ryan Barry
URL:
Whiteboard:
: 1635574 (view as bug list)
Depends On: 1631361
Blocks: 1636946
TreeView+ depends on / blocked
 
Reported: 2018-09-20 12:12 UTC by Michal Skrivanek
Modified: 2019-11-15 15:23 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.3.0_alpha
Doc Type: Bug Fix
Doc Text:
The previous release changed the system manufacturer of virtual machines from "Red Hat" to "oVirt". This was inconsistent with preceding versions. Some users depended on this field to determine the underlying hypervisor. The current release fixes this issue by setting the SMBIOS manufacturer according to the product being used, which is indicated by the 'OriginType' configuration value. As a result, the manufacturer is set to 'oVirt' when oVirt is being used, and 'Red Hat' when Red Hat Virtualization is being used.
Clone Of:
: 1631361 1636946 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:38:22 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:38:39 UTC
oVirt gerrit 94444 0 master MERGED core: configurable SMBIOS manufacturer 2020-12-07 14:38:50 UTC
oVirt gerrit 94446 0 ovirt-engine-4.2 MERGED core: configurable SMBIOS manufacturer 2020-12-07 14:38:50 UTC

Description Michal Skrivanek 2018-09-20 12:12:46 UTC
we now have "oVirt" everywhere, that's a regression in 4.2

Comment 3 Ryan Barry 2018-10-08 12:18:22 UTC
*** Bug 1635574 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2019-05-08 12:38:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.