Bug 1631666 - AVC denial by tomcat, reading /dev/random
Summary: AVC denial by tomcat, reading /dev/random
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1632738 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-21 08:50 UTC by Jan Pazdziora
Modified: 2018-10-30 10:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:09:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:10:52 UTC

Description Jan Pazdziora 2018-09-21 08:50:40 UTC
Description of problem:

When IPA server is being configured via ipa-server-install which also starts pki-tomcat, AVC denial is recorded.

Version-Release number of selected component (if applicable):

tomcat-7.0.76-6.el7.noarch
pki-server-10.5.9-6.el7.noarch
ipa-server-4.6.4-10.el7.x86_64
selinux-policy-3.13.1-227.el7.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. yum install -y ipa-server
2. ipa-server-install --setup-dns --forwarder=10.11.12.13 -r EXAMPLE.TEST -n example.test -p Secret123 -a Secret123 -U
3. Check audit.log

Actual results:

type=SYSCALL msg=audit(1537439475.876:461): arch=c000003e syscall=6 success=no exit=-13 a0=7f842f314270 a1=7f842f313140 a2=7f842f313140 a3=b items=1 ppid=1 pid=21610 auid=4294967295 uid=17 gid=17 euid=17 suid=17 fsuid=17 egid=17 sgid=17 fsgid=17 tty=(none) ses=4294967295 comm="java" exe="/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.181-7.b13.el7.x86_64/jre/bin/java" subj=system_u:system_r:tomcat_t:s0 key=(null)
type=AVC msg=audit(1537439475.876:461): avc:  denied  { getattr } for  pid=21610 comm="java" path="/dev/random" dev="devtmpfs" ino=1032 scontext=system_u:system_r:tomcat_t:s0 tcontext=system_u:object_r:random_device_t:s0 tclass=chr_file permissive=0

Expected results:

No AVC denial.

Additional info:

I'm filing against tomcat because I don't know if some change happened in tomcat, pki-tomcat, something else in IPA/IdM, or in selinux-policy. Feel free to move to different component.

Comment 6 Milos Malik 2018-09-21 17:29:28 UTC
Even if the denial appeared multiple times, both services start and run successfully:

 * /usr/lib/systemd/system/tomcat-jsvc.service
 * /usr/lib/systemd/system/tomcat.service

Comment 9 Lukas Vrabec 2018-09-25 12:27:44 UTC
*** Bug 1632738 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2018-10-30 10:09:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.