Bug 1631744 - Full reload of the tuned daemon on SIGHUP
Summary: Full reload of the tuned daemon on SIGHUP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks: 1630913
TreeView+ depends on / blocked
 
Reported: 2018-09-21 13:00 UTC by jmencak
Modified: 2019-08-06 13:05 UTC (History)
8 users (show)

Fixed In Version: tuned-2.11.0-0.1.rc1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:04:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github redhat-performance tuned pull 143 None closed Reload profile configuration on SIGHUP 2020-04-17 06:08:36 UTC
Red Hat Product Errata RHBA-2019:2201 None None None 2019-08-06 13:05:15 UTC

Description jmencak 2018-09-21 13:00:16 UTC
Description of problem:
There is a handler for catching SIGHUP in the tuned daemon.  The handler reloads the tuned controller, but it does not apply a new profile like a full tuned restart, when invoked by 'systemctl restart tuned' for example.  In other words, the signal handler should make sure a new (if any) profile is also applied on SIGHUP.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1. cd /etc/tuned && echo my-new-profile > active_profile && echo manual > profile_mode
2. pkill -HUP -f tuned
3. tuned-adm profile | grep active # sill shows the old profile
4. systemctl restart tuned # will apply my-new-profile

Actual results:
Old profile used after step 2.

Expected results:
New profile used after step 2.

Comment 3 Ondřej Lysoněk 2018-09-21 13:21:08 UTC
I tend to agree. I think the SIGHUP handler should have the same effect as doing a Tuned restart. So we need to reload from disk /etc/tuned/active_profile, /etc/tuned/profile_mode, all recommend.conf files and the profile that is to be activated.

Comment 4 Jaroslav Škarvada 2018-09-21 16:18:00 UTC
(In reply to Ondřej Lysoněk from comment #3)
> I tend to agree. I think the SIGHUP handler should have the same effect as
> doing a Tuned restart. So we need to reload from disk
> /etc/tuned/active_profile, /etc/tuned/profile_mode, all recommend.conf files
> and the profile that is to be activated.

+1

Comment 6 Ondřej Lysoněk 2019-01-15 13:04:49 UTC
A fix for this is waiting to be merged upstream. Jardo, can you take a look at it? Thanks!

Comment 7 Ondřej Lysoněk 2019-01-31 16:12:11 UTC
Dropping needinfo, the fix got merged now.

Comment 13 errata-xmlrpc 2019-08-06 13:04:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2201


Note You need to log in before you can comment on or make changes to this bug.