Bug 1631764 - globus-gssapi-gsi is incompatible with openssl-1.0.1e
Summary: globus-gssapi-gsi is incompatible with openssl-1.0.1e
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: globus-gssapi-gsi   
(Show other bugs)
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-21 13:56 UTC by Brian Bockelman
Modified: 2018-10-16 10:29 UTC (History)
2 users (show)

Fixed In Version: globus-gssapi-gsi-14.7-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-16 10:29:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Bockelman 2018-09-21 13:56:52 UTC
Description of problem:

It appears that the latest globus-gssapi-gsi (globus-gssapi-gsi-13.8-1.el7.x86_64) links against the symbol `SSL_set_alpn_protos`.  This symbol does not appear in openssl-1.0.1e (RHEL 7.3-era) but is in openssl-1.0.2k (most recent).

Since the library version did not change in OpenSSL, the automatic RPM dependency generator did not catch this incompatibility.

Version-Release number of selected component (if applicable):

globus-gssapi-gsi-13.8-1.el7.x86_64

How reproducible:

Mix the latest globus-gssapi-gsi with the RHEL7.3 OpenSSL; anything that tries to load libglobus_gssapi_gsi (probably even globus-url-copy) will fail.


In the end, I think it's quite fair to say that this particular combination is unsupported.  However, it would have saved some of our sysadmins days of debugging time if the RPM listed the versioned dependency on OpenSSL explicitly.  Can this package get that tweak?

Comment 1 Fedora Update System 2018-09-22 04:38:05 UTC
globus-authz-4.1-1.el7 globus-authz-callout-error-4.0-1.el7 globus-callout-4.0-1.el7 globus-common-18.0-1.el7 globus-ftp-client-9.1-1.el7 globus-ftp-control-9.3-1.el7 globus-gass-cache-10.0-1.el7 globus-gass-cache-program-7.0-1.el7 globus-gass-copy-10.3-1.el7 globus-gass-server-ez-6.0-1.el7 globus-gass-transfer-9.0-1.el7 globus-gatekeeper-11.0-1.el7 globus-gfork-5.0-1.el7 globus-gram-audit-5.0-1.el7 globus-gram-client-14.1-1.el7 globus-gram-client-tools-12.0-1.el7 globus-gram-job-manager-15.1-1.el7 globus-gram-job-manager-callout-error-4.0-1.el7 globus-gram-job-manager-condor-3.0-1.el7 globus-gram-job-manager-fork-3.0-1.el7 globus-gram-job-manager-lsf-3.0-1.el7 globus-gram-job-manager-pbs-3.0-1.el7 globus-gram-job-manager-scripts-7.0-1.el7 globus-gram-job-manager-sge-3.0-1.el7 globus-gram-job-manager-slurm-3.0-1.el7 globus-gram-protocol-13.1-1.el7 globus-gridftp-server-13.8-1.el7 globus-gridftp-server-control-8.0-1.el7 globus-gridmap-callout-error-3.0-1.el7 globus-gridmap-eppn-callout-2.0-1.el7 globus-gridmap-verify-myproxy-callout-3.0-1.el7 globus-gsi-callback-6.0-1.el7 globus-gsi-cert-utils-10.0-1.el7 globus-gsi-credential-8.0-1.el7 globus-gsi-openssl-error-4.0-1.el7 globus-gsi-proxy-core-9.1-1.el7 globus-gsi-proxy-ssl-6.0-1.el7 globus-gsi-sysconfig-9.1-1.el7 globus-gss-assist-12.1-1.el7 globus-gssapi-error-6.0-1.el7 globus-gssapi-gsi-14.7-2.el7 globus-io-12.1-1.el7 globus-net-manager-1.1-1.el7 globus-openssl-module-5.0-1.el7 globus-proxy-utils-7.1-1.el7 globus-rsl-11.0-1.el7 globus-scheduler-event-generator-6.0-1.el7 globus-simple-ca-5.0-1.el7 globus-usage-5.0-1.el7 globus-xio-6.0-1.el7 globus-xio-gridftp-driver-3.1-1.el7 globus-xio-gridftp-multicast-2.0-1.el7 globus-xio-gsi-driver-5.0-1.el7 globus-xio-pipe-driver-4.0-1.el7 globus-xio-popen-driver-4.0-1.el7 globus-xio-rate-driver-2.0-1.el7 globus-xio-udt-driver-2.0-1.el7 globus-xioperf-5.0-1.el7 myproxy-6.2.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-8aebaba2a9

Comment 2 Fedora Update System 2018-09-22 20:55:23 UTC
globus-authz-4.1-1.el7, globus-authz-callout-error-4.0-1.el7, globus-callout-4.0-1.el7, globus-common-18.0-1.el7, globus-ftp-client-9.1-1.el7, globus-ftp-control-9.3-1.el7, globus-gass-cache-10.0-1.el7, globus-gass-cache-program-7.0-1.el7, globus-gass-copy-10.3-1.el7, globus-gass-server-ez-6.0-1.el7, globus-gass-transfer-9.0-1.el7, globus-gatekeeper-11.0-1.el7, globus-gfork-5.0-1.el7, globus-gram-audit-5.0-1.el7, globus-gram-client-14.1-1.el7, globus-gram-client-tools-12.0-1.el7, globus-gram-job-manager-15.1-1.el7, globus-gram-job-manager-callout-error-4.0-1.el7, globus-gram-job-manager-condor-3.0-1.el7, globus-gram-job-manager-fork-3.0-1.el7, globus-gram-job-manager-lsf-3.0-1.el7, globus-gram-job-manager-pbs-3.0-1.el7, globus-gram-job-manager-scripts-7.0-1.el7, globus-gram-job-manager-sge-3.0-1.el7, globus-gram-job-manager-slurm-3.0-1.el7, globus-gram-protocol-13.1-1.el7, globus-gridftp-server-13.8-1.el7, globus-gridftp-server-control-8.0-1.el7, globus-gridmap-callout-error-3.0-1.el7, globus-gridmap-eppn-callout-2.0-1.el7, globus-gridmap-verify-myproxy-callout-3.0-1.el7, globus-gsi-callback-6.0-1.el7, globus-gsi-cert-utils-10.0-1.el7, globus-gsi-credential-8.0-1.el7, globus-gsi-openssl-error-4.0-1.el7, globus-gsi-proxy-core-9.1-1.el7, globus-gsi-proxy-ssl-6.0-1.el7, globus-gsi-sysconfig-9.1-1.el7, globus-gss-assist-12.1-1.el7, globus-gssapi-error-6.0-1.el7, globus-gssapi-gsi-14.7-2.el7, globus-io-12.1-1.el7, globus-net-manager-1.1-1.el7, globus-openssl-module-5.0-1.el7, globus-proxy-utils-7.1-1.el7, globus-rsl-11.0-1.el7, globus-scheduler-event-generator-6.0-1.el7, globus-simple-ca-5.0-1.el7, globus-usage-5.0-1.el7, globus-xio-6.0-1.el7, globus-xio-gridftp-driver-3.1-1.el7, globus-xio-gridftp-multicast-2.0-1.el7, globus-xio-gsi-driver-5.0-1.el7, globus-xio-pipe-driver-4.0-1.el7, globus-xio-popen-driver-4.0-1.el7, globus-xio-rate-driver-2.0-1.el7, globus-xio-udt-driver-2.0-1.el7, globus-xioperf-5.0-1.el7, myproxy-6.2.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-8aebaba2a9

Comment 3 Brian Bockelman 2018-09-26 17:59:31 UTC
I can confirm the new Requires statement shows up in globus-gssapi-gsi-14.7-2.*

Looks good to me.

Comment 4 Fedora Update System 2018-10-16 10:29:03 UTC
globus-authz-4.1-1.el7, globus-authz-callout-error-4.0-1.el7, globus-callout-4.0-1.el7, globus-common-18.0-1.el7, globus-ftp-client-9.1-1.el7, globus-ftp-control-9.3-1.el7, globus-gass-cache-10.0-1.el7, globus-gass-cache-program-7.0-1.el7, globus-gass-copy-10.3-1.el7, globus-gass-server-ez-6.0-1.el7, globus-gass-transfer-9.0-1.el7, globus-gatekeeper-11.0-1.el7, globus-gfork-5.0-1.el7, globus-gram-audit-5.0-1.el7, globus-gram-client-14.1-1.el7, globus-gram-client-tools-12.0-1.el7, globus-gram-job-manager-15.1-1.el7, globus-gram-job-manager-callout-error-4.0-1.el7, globus-gram-job-manager-condor-3.0-1.el7, globus-gram-job-manager-fork-3.0-1.el7, globus-gram-job-manager-lsf-3.0-1.el7, globus-gram-job-manager-pbs-3.0-1.el7, globus-gram-job-manager-scripts-7.0-1.el7, globus-gram-job-manager-sge-3.0-1.el7, globus-gram-job-manager-slurm-3.0-1.el7, globus-gram-protocol-13.1-1.el7, globus-gridftp-server-13.8-1.el7, globus-gridftp-server-control-8.0-1.el7, globus-gridmap-callout-error-3.0-1.el7, globus-gridmap-eppn-callout-2.0-1.el7, globus-gridmap-verify-myproxy-callout-3.0-1.el7, globus-gsi-callback-6.0-1.el7, globus-gsi-cert-utils-10.0-1.el7, globus-gsi-credential-8.0-1.el7, globus-gsi-openssl-error-4.0-1.el7, globus-gsi-proxy-core-9.1-1.el7, globus-gsi-proxy-ssl-6.0-1.el7, globus-gsi-sysconfig-9.1-1.el7, globus-gss-assist-12.1-1.el7, globus-gssapi-error-6.0-1.el7, globus-gssapi-gsi-14.7-2.el7, globus-io-12.1-1.el7, globus-net-manager-1.1-1.el7, globus-openssl-module-5.0-1.el7, globus-proxy-utils-7.1-1.el7, globus-rsl-11.0-1.el7, globus-scheduler-event-generator-6.0-1.el7, globus-simple-ca-5.0-1.el7, globus-usage-5.0-1.el7, globus-xio-6.0-1.el7, globus-xio-gridftp-driver-3.1-1.el7, globus-xio-gridftp-multicast-2.0-1.el7, globus-xio-gsi-driver-5.0-1.el7, globus-xio-pipe-driver-4.0-1.el7, globus-xio-popen-driver-4.0-1.el7, globus-xio-rate-driver-2.0-1.el7, globus-xio-udt-driver-2.0-1.el7, globus-xioperf-5.0-1.el7, myproxy-6.2.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.