Bug 1631772 - multipathd: "errors" during normal boot
Summary: multipathd: "errors" during normal boot
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath (Show other bugs)
(Show other bugs)
Version: 29
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Marzinski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-21 14:22 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2019-01-18 02:13 UTC (History)
9 users (show)

Fixed In Version: device-mapper-multipath-0.7.7-6.gitef6d98b.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-01-18 02:13:58 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot from qemu boot (10.99 KB, image/png)
2019-01-15 08:32 UTC, Zbigniew Jędrzejewski-Szmek
no flags Details

Description Zbigniew Jędrzejewski-Szmek 2018-09-21 14:22:35 UTC
Description of problem:
multipathd logs during boot at error level:
Sep 21 15:51:51 multipathd[560]: /etc/multipath.conf does not exist, blacklisting all devices.
Sep 21 15:51:51 multipathd[560]: You can run "/sbin/mpathconf --enable" to create
Sep 21 15:51:51 multipathd[560]: /etc/multipath.conf. See man mpathconf(8) for more details
S

Not having any multipath devices is completely mundane, the service should not report this as an error. See https://fedoraproject.org/wiki/Packaging:DefaultServices#Must_not_fail_under_normal_operating_conditions

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.7.7-4.gitef6d98b.fc29.x86_64

Expected results:
A single log line at info level, "/etc/multipath.conf does not exist, multipathd exiting" or something like that.

Comment 1 Ben Marzinski 2018-09-24 19:42:59 UTC
This only happens when manually running multipathd, correct? Manually starting multipathd without a configuration file is not completely mundade. It's something that should never happen.

Systemd refuses to start the service because of

ConditionPathExists=/etc/multipath.conf

in multipathd.service

Which will keep you from ever seeing this message. So, unless I'm missing something, you have to manually run multipathd to see this, which you should not be doing anyway. You should start it via systemd. I would argue that if someone thinks that they have correctly started multipathd but they haven't, that's important information.  Is there some situation during boot where something is trying to start multipathd not through systemd?

Comment 2 Zbigniew Jędrzejewski-Szmek 2018-09-24 21:17:16 UTC
I omitted an important bit of information: this is on silverblue (F29-beta5 amd64 silverblue image under qemu). This might or might not be relevant.

> This only happens when manually running multipathd, correct?

No, I'm not starting anything manually. This error message is from the logs from a default boot after installation.

The .service has ConditionPathExists=/etc/multipath.conf, but .socket does not. I guess the service is started when something connects to the socket.

Comment 3 Zbigniew Jędrzejewski-Szmek 2019-01-15 08:32 UTC
Created attachment 1520673 [details]
screenshot from qemu boot

Can we please get this fixed? When booting a Workstation-live image (and xfce, and probably others), this is prominently visible during but and *very* ugly. People are putting a lot of effort into polish, and stuff like this completely defeats it.

Please see attached screenshot from
qemu-system-x86_64 -machine accel=kvm -smp 2 -m 2048 -drive if=pflash,format=raw,readonly,file=/usr/share/edk2/ovmf/OVMF_CODE.fd -cdrom Workstation-Live-x86_64-Rawhide-20190114.n.0.iso

Comment 4 Fedora Update System 2019-01-15 23:08:36 UTC
device-mapper-multipath-0.7.7-6.gitef6d98b.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e969fe2844

Comment 5 Fedora Update System 2019-01-16 03:31:33 UTC
device-mapper-multipath-0.7.7-6.gitef6d98b.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e969fe2844

Comment 6 Fedora Update System 2019-01-18 02:13:58 UTC
device-mapper-multipath-0.7.7-6.gitef6d98b.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.