Bug 1631790 - rpm-ostree error Txn AutomaticUpdateTrigger on /org/projectatomic/rpmostree1/fedora_workstation failed: [7] Couldn't connect to server
Summary: rpm-ostree error Txn AutomaticUpdateTrigger on /org/projectatomic/rpmostree1/...
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm-ostree
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-21 14:59 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2018-09-21 15:29 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-09-21 15:29:06 UTC


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2018-09-21 14:59:18 UTC
Description of problem:
I'm testing F29-beta5 amd64 silverblue image under qemu.
I get errors in the logs from rpm-ostree.

$ journalctl -b --no-hostname -p err --no-pager
Sep 21 15:53:46 rpm-ostree[1953]: Txn AutomaticUpdateTrigger on /org/projectatomic/rpmostree1/fedora_workstation failed: [7] Couldn't connect to server
Sep 21 15:54:14 rpm-ostree[1953]: Txn AutomaticUpdateTrigger on /org/projectatomic/rpmostree1/fedora_workstation failed: [7] Couldn't connect to server

Those errors are non-actionable without information *what* server is being contacted. The network works in general, I can ping hosts.

Version-Release number of selected component (if applicable):
rpm-ostree-2018.7-1.fc29.x86_64

Steps to reproduce:
$ install and boot F29 beta
$ journalctl -b -p err

Actual results:
errors reported in log

Expected results:
nothing

Comment 1 Dusty Mabe 2018-09-21 15:08:31 UTC
can you cat /etc/ostree/remotes.d/*.conf ? That should let you know what server was attempted to be contacted.

If you want the server printed out in the logs then maybe open an RFE at github.com/projectatomic/rpm-ostree

Comment 2 Jonathan Lebon 2018-09-21 15:10:07 UTC
I opened https://github.com/ostreedev/ostree/issues/1731.

Comment 3 Zbigniew Jędrzejewski-Szmek 2018-09-21 15:29:06 UTC
[fedora@localhost ~]$ ls /etc/ostree/remotes.d/
fedora-workstation.conf
[fedora@localhost ~]$ cat /etc/ostree/remotes.d/fedora-workstation.conf 
[remote "fedora-workstation"]
url=https://kojipkgs.fedoraproject.org/atomic/repo/
gpg-verify=true
gpgkeypath=/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-29-primary

It seems I have some network issue with the fedora servers:
$ ping kojipkgs.fedoraproject.org
PING kojipkgs.fedoraproject.org (209.132.181.16) 56(84) bytes of data.
64 bytes from proxy01.fedoraproject.org (209.132.181.16): icmp_seq=1 ttl=47 time=194 ms
64 bytes from proxy01.fedoraproject.org (209.132.181.16): icmp_seq=2 ttl=47 time=203 ms
^C
$ curl https://kojipkgs.fedoraproject.org/atomic/repo/
(hangs)

OK, so I'll close this as UPSTREAM, for the RFE, and close this here since the actual error seems to be a network issue.


Note You need to log in before you can comment on or make changes to this bug.