Bug 1631801 - avc errors for geoclue
Summary: avc errors for geoclue
Status: CLOSED DUPLICATE of bug 1625632
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 29
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-21 15:15 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2018-09-23 19:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-09-23 19:01:37 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2018-09-21 15:15:16 UTC
Description of problem:
I'm testing F29-beta5 amd64 silverblue image under qemu.
I get errors in the logs from rpm-ostree.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.14.2-34.fc29.noarch
GeoIP-1.6.12-4.fc29.x86_64

How reproducible:
reproducible during normal boot

Steps to Reproduce:
1. install and boot Fedora-Silverblue-ostree-x86_64-29_Beta-1.5.iso
2. journalctl -b
3.

Actual results:
Sep 21 15:52:44 audit[2091]: AVC avc:  denied  { execute } for  pid=2091 comm="geoclue" path=2F746D702F66666944594D6F3762202864656C6574656429 dev="tmpfs" ino=41445 scontext=system_u:system_r:geoclue_t:s0 tcontext=system_u:object_r:geoclue_tmp_t:s0 tclass=file permissive=0
Sep 21 15:52:44 audit[2091]: AVC avc:  denied  { execute } for  pid=2091 comm="geoclue" path=2F7661722F746D702F666669613577785933202864656C6574656429 dev="dm-0" ino=263451 scontext=system_u:system_r:geoclue_t:s0 tcontext=system_u:object_r:geoclue_tmp_t:s0 tclass=file permissive=0
Sep 21 15:52:44 audit[2091]: AVC avc:  denied  { write } for  pid=2091 comm="geoclue" name="/" dev="tmpfs" ino=41 scontext=system_u:system_r:geoclue_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=dir permissive=0

Comment 1 Lukas Vrabec 2018-09-23 19:01:37 UTC

*** This bug has been marked as a duplicate of bug 1625632 ***


Note You need to log in before you can comment on or make changes to this bug.