Bug 16320 - update disks won't work on a HP omnibook 4100
update disks won't work on a HP omnibook 4100
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Erik Troan
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-16 06:48 EDT by Pekka Pietikäinen
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 13:07:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2000-08-16 06:48:41 EDT
When trying to use an update disk on a laptop  where you can't have the CD
and floppy drives connected at the same time loading the updates works
(replacing the cd-rom drive with the floppy drive when the dialog comes
up), but switching back the kernel/installer get very confused and end up
just rebooting the system.

For a possible fix in future releases, maybe look for errors reading the CD
after loading floppies, and give a dialog giving the option to retry the
previous operation or just rebooting.

In any case, this bug will not be a problem unless the installer on the CD
is broken...
Comment 1 Erik Troan 2000-08-16 08:29:27 EDT
The kernel really doesn't support flipping drives in laptop's well. Michael, I
expect you to call this a WONTFIX, but I thought I'd give you the chance ;-)
Comment 2 Pekka Pietikäinen 2000-08-16 08:43:28 EDT
Nah, the kernel is fine with this, the problem is with the installer trying to
access the cd-rom before I
have managed to plug it back in :) 

[root@pcitpdp17 linux]# mount /dev/cdrom
mount: block device /dev/cdrom is write-protected, mounting read-only
[root@pcitpdp17 linux]# ls /mnt/cdrom/
COPYING  README  RPM-GPG-KEY  SRPMS  TRANS.TBL
<hotswap>
[root@pcitpdp17 linux]# mount /dev/fd0
[root@pcitpdp17 linux]# ls /mnt/floppy 
fstab.py  image.py  lost+found
[root@pcitpdp17 linux]# umount /mnt/floppy
<hotswap>
[root@pcitpdp17 linux]# ls /mnt/cdrom/
COPYING  README  RPM-GPG-KEY  SRPMS  TRANS.TBL
[root@pcitpdp17 linux]# 

No errors in dmesg either.
Comment 3 Michael K. Johnson 2000-08-16 12:44:37 EDT
Yeah, ewt, pp is right, this isn't my problem.  Tag, you're it.
Comment 4 Erik Troan 2000-08-16 13:05:52 EDT
Oh, shit.

Hmmm, I don't know quite what to do about this. Doesn't it time out and let you
try again?
Comment 5 Erik Troan 2000-08-16 13:07:45 EDT
Oh, ick. I see what you mean now.

The CD is actually *mounted* when you unplug it. This is really hard to get
right (methinks the
kernel's retry-after-failure should be able to handle this better though) in
userspace.

Note You need to log in before you can comment on or make changes to this bug.