Bug 1632216 - update julia would remove dnf??
Summary: update julia would remove dnf??
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: julia
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Bouchet-Valat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-24 11:23 UTC by Neal Becker
Modified: 2018-10-09 00:05 UTC (History)
1 user (show)

Fixed In Version: julia-1.0.1-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-09 00:05:13 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Neal Becker 2018-09-24 11:23:20 UTC
Description of problem:

Seems to be a packaging issue, see discussion:

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/S2ZIWQTRL3EYYPXC2HKUQQZGVC2APTXY/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Milan Bouchet-Valat 2018-09-25 12:22:38 UTC
Good catch. I have a fix locally, I will a push it with the new 1.0.1 release in a few days.

Comment 2 Neal Becker 2018-10-01 00:18:01 UTC
Some more deps problems today.  This time just using F28 repos:

sudo dnf update
...
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package julia-0.7.0-copr3.fc28.x86_64
  - nothing provides libLLVM-6.0.so(JL_LLVM_6.0)(64bit) needed by julia-1.0.1-1.fc28.x86_64
 Problem 2: cannot install the best update candidate for package julia-devel-0.7.0-copr3.fc28.x86_64
  - nothing provides libLLVM-6.0.so(JL_LLVM_6.0)(64bit) needed by julia-devel-1.0.1-1.fc28.x86_64
 Problem 3: package julia-doc-1.0.1-1.fc28.noarch requires julia = 1.0.1-1.fc28, but none of the providers can be installed
  - cannot install the best update candidate for package julia-doc-0.7.0-copr3.fc28.x86_64
  - nothing provides libLLVM-6.0.so(JL_LLVM_6.0)(64bit) needed by julia-1.0.1-1.fc28.x86_64
 Problem 4: package julia-common-1.0.1-1.fc28.noarch requires julia = 1.0.1-1.fc28, but none of the providers can be installed
  - cannot install the best update candidate for package julia-common-0.7.0-copr3.fc28.x86_64
  - nothing provides libLLVM-6.0.so(JL_LLVM_6.0)(64bit) needed by julia-1.0.1-1.fc28.x86_64

Comment 3 Fedora Update System 2018-10-01 17:22:56 UTC
julia-1.0.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-fac12a17a2

Comment 4 Fedora Update System 2018-10-01 21:59:20 UTC
julia-1.0.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-fac12a17a2

Comment 5 Fedora Update System 2018-10-03 12:28:54 UTC
julia-1.0.1-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8841a78d87

Comment 6 Milan Bouchet-Valat 2018-10-03 12:34:20 UTC
Damn, these things are definitely tricky. I've pushed another update which should fix this.

Comment 7 Fedora Update System 2018-10-03 16:31:15 UTC
julia-1.0.1-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8841a78d87

Comment 8 Fedora Update System 2018-10-06 18:20:52 UTC
dislocker-0.7.1-10.fc29 dolphin-emu-5.0-25.fc29 julia-1.0.1-3.fc29 mbedtls-2.13.0-1.fc29 nekovm-2.2.0-8.fc29 nng-1.0.1-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c6b5117772

Comment 9 Fedora Update System 2018-10-06 20:36:45 UTC
julia-1.0.1-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8841a78d87

Comment 10 Fedora Update System 2018-10-07 23:35:19 UTC
dislocker-0.7.1-10.fc29, dolphin-emu-5.0-25.fc29, julia-1.0.1-3.fc29, mbedtls-2.13.0-1.fc29, nekovm-2.2.0-8.fc29, nng-1.0.1-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c6b5117772

Comment 11 Fedora Update System 2018-10-07 23:35:31 UTC
julia-1.0.1-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8841a78d87

Comment 12 Fedora Update System 2018-10-09 00:05:13 UTC
dislocker-0.7.1-10.fc29, dolphin-emu-5.0-25.fc29, julia-1.0.1-3.fc29, mbedtls-2.13.0-1.fc29, nekovm-2.2.0-8.fc29, nng-1.0.1-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.