Bug 1632626 - only "katello" and "satellite" rpms require java-1.7.0-openjdk*, candlepin requires java-1.8.0
Summary: only "katello" and "satellite" rpms require java-1.7.0-openjdk*, candlepin re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Released
Assignee: Eric Helms
QA Contact: Jan Hutař
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-25 09:23 UTC by Jan Hutař
Modified: 2019-10-07 17:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:38:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:38:10 UTC

Description Jan Hutař 2018-09-25 09:23:10 UTC
Description of problem:
Only "katello" and "satellite" rpms require java-1.7.0-openjdk*, candlepin requires java-1.8.0. If this dependency is still needed, IMO respective package should require it, not these meta-packages. Also this "< 1:1.8.0.45" requirements might need to be revisited (see bug 1628111).


Version-Release number of selected component (if applicable):
katello-3.7.0-8.el7sat.noarch
satellite-6.4.0-15.el7sat.noarch


How reproducible:
always


Steps to Reproduce:
1. # rpm -q --requires katello satellite | grep java
   java-openjdk >= 1:1.7.0
   java-openjdk < 1:1.8.0.45
2. # yum remove java-1.7.0-openjdk java-1.7.0-openjdk-headless | tee
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package java-1.7.0-openjdk.x86_64 1:1.7.0.191-2.6.15.4.el7_5 will be erased
--> Processing Dependency: java-openjdk < 1:1.8.0.45 for package: katello-3.7.0-8.el7sat.noarch
---> Package java-1.7.0-openjdk-headless.x86_64 1:1.7.0.191-2.6.15.4.el7_5 will be erased
--> Running transaction check
---> Package katello.noarch 0:3.7.0-8.el7sat will be erased
--> Processing Dependency: katello >= 3.7.0 for package: satellite-6.4.0-15.el7sat.noarch
--> Running transaction check
---> Package satellite.noarch 0:6.4.0-15.el7sat will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch   Version                    Repository           Size
================================================================================
Removing:
 java-1.7.0-openjdk x86_64 1:1.7.0.191-2.6.15.4.el7_5 @rhel-7-server-rpms 554 k
 java-1.7.0-openjdk-headless
                    x86_64 1:1.7.0.191-2.6.15.4.el7_5 @rhel-7-server-rpms  92 M
Removing for dependencies:
 katello            noarch 3.7.0-8.el7sat             @Sat6-CI_Red_Hat_Satellite_6_4_Composes_Satellite_6_4_RHEL7
                                                                          0.0  
 satellite          noarch 6.4.0-15.el7sat            @Sat6-CI_Red_Hat_Satellite_6_4_Composes_Satellite_6_4_RHEL7
                                                                          0.0  

Transaction Summary
================================================================================
Remove  2 Packages (+2 Dependent packages)


Actual results:
Dependency on java-1.7.0-openjdk does not permit me to remove java-1.7.0-openjdk* packages.


Expected results:
We should check if we still need Java 1.7.0 and if yes, dependency should be moved to the proper package to make investigating requirements easier.

Comment 5 errata-xmlrpc 2019-05-14 12:38:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.