Bug 163276 - baudboy.h should include fcntl.h
Summary: baudboy.h should include fcntl.h
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lockdev   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-14 18:34 UTC by Chris Adams
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-01 14:48:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Adams 2005-07-14 18:34:31 UTC
/usr/include/baudboy.h should include fcntl.h because it uses open().  If you
don't first include fcntl.h, open() will get an implicit definition (which is
usually bad and won't compile).

I think this hasn't been noticed because current baudboy.h users include fcntl.h
themselves first.  I'm building ckermit with baudboy.h and it doesn't include
fcntl.h, so it won't compile.


Note You need to log in before you can comment on or make changes to this bug.