Bug 1632870 - Add support for only installing and running the schema installer job
Summary: Add support for only installing and running the schema installer job
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.10.z
Assignee: Ruben Vargas Palma
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1626908 (view as bug list)
Depends On: 1632869
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-25 17:53 UTC by John Sanda
Modified: 2019-07-09 07:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1632869
Environment:
Last Closed: 2019-01-10 09:27:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0026 None None None 2019-01-10 09:27:16 UTC

Description John Sanda 2018-09-25 17:53:48 UTC
+++ This bug was initially created as a clone of Bug #1632869 +++

Description of problem:
There is no easy way to rerun a Kubernetes job. As discussed in bug 1632852 there are times when the job terminates with a failure and does not run again. In that sort of scenario the job has to be recreated in order for it to run again. This should be automated through the installer.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vadim Rutkovsky 2018-10-18 09:34:01 UTC
Fix is available in openshift-ansible-3.10.59-1

Comment 2 Junqi Zhao 2018-10-22 09:00:40 UTC
Tested with openshift-ansible-3.10.60-1, issue is fixed.

Steps:
scale down cassandra and hawkular-metrics rc, after a while, scale them up.
There are error in hawkular-metrics pod, "The schema version check failed". Then run the playbooks/openshift-metrics/schema.yml playbook, all pods will be running well.

# oc -n openshift-infra get pod
NAME                            READY     STATUS      RESTARTS   AGE
hawkular-cassandra-1-l4zpg      1/1       Running     0          28m
hawkular-metrics-lzz5g          1/1       Running     3          28m
hawkular-metrics-schema-9qlxd   0/1       Completed   0          5m
heapster-tnq2m                  1/1       Running     2          1h

NOTE: heapster should also be scale down and scale up avoid not showing metrics diagram in web UI.

Comment 3 Ruben Vargas Palma 2018-12-10 18:21:28 UTC
*** Bug 1626908 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2019-01-10 09:27:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0026


Note You need to log in before you can comment on or make changes to this bug.