Bug 163295 - need way to push multiple updates at once
need way to push multiple updates at once
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: update system (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-14 17:28 EDT by Bill Nottingham
Modified: 2016-09-19 22:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-18 20:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-07-14 17:28:33 EDT
Since the overriding time expenditure in the push process is the metadata
generation (yum-arch/createrepo), it would be good to be able to select multiple
updates and push them all at once, only running the metadata generation once for
the set of them.
Comment 1 Luke Macken 2005-07-18 16:21:20 EDT
Done.
Comment 2 Bill Nottingham 2005-07-18 19:57:06 EDT
When pushing multiple updates, it looks like:

Pushing firefox-1.0.6-0.1.fc3...

Coping firefox-1.0.6-0.1.fc3 from
/mnt/redhat/beehive/comps/dist/fc3-updates-candidate/firefox/1.0.6-0.1.fc3/ to
/mnt/redhat/fedora/updates-stage//testing/3//

/mnt/redhat/beehive/comps/dist/fc3-updates-candidate/firefox/1.0.6-0.1.fc3//SRPMS/firefox-1.0.6-0.1.fc3.src.rpm
=> /mnt/redhat/fedora/updates-stage//testing/3/SRPMS//firefox-1.0.6-0.1.fc3.src.rpm
/mnt/redhat/beehive/comps/dist/fc3-updates-candidate/firefox/1.0.6-0.1.fc3//i386/firefox-1.0.6-0.1.fc3.i386.rpm
=> /mnt/redhat/fedora/updates-stage//testing/3/i386//firefox-1.0.6-0.1.fc3.i386.rpm
/mnt/redhat/beehive/comps/dist/fc3-updates-candidate/firefox/1.0.6-0.1.fc3//i386/firefox-debuginfo-1.0.6-0.1.fc3.i386.rpm
=>
/mnt/redhat/fedora/updates-stage//testing/3/i386//debug/firefox-debuginfo-1.0.6-0.1.fc3.i386.rpm
/mnt/redhat/beehive/comps/dist/fc3-updates-candidate/firefox/1.0.6-0.1.fc3//x86_64/firefox-1.0.6-0.1.fc3.x86_64.rpm
=>
/mnt/redhat/fedora/updates-stage//testing/3/x86_64//firefox-1.0.6-0.1.fc3.x86_64.rpm
/mnt/redhat/beehive/comps/dist/fc3-updates-candidate/firefox/1.0.6-0.1.fc3//x86_64/firefox-debuginfo-1.0.6-0.1.fc3.x86_64.rpm
=>
/mnt/redhat/fedora/updates-stage//testing/3/x86_64//debug/firefox-debuginfo-1.0.6-0.1.fc3.x86_64.rpm

Assigning unique update id

Sending notification mail to caillon@redhat.com

Pushing firefox-1.0.6-0.1.fc4...

Coping firefox-1.0.6-0.1.fc4 from
/mnt/redhat/beehive/comps/dist/fc4-updates-candidate/firefox/1.0.6-0.1.fc4/ to
/mnt/redhat/fedora/updates-stage//testing/4//

/mnt/redhat/beehive/comps/dist/fc4-updates-candidate/firefox/1.0.6-0.1.fc4//SRPMS/firefox-1.0.6-0.1.fc4.src.rpm
=> /mnt/redhat/fedora/updates-stage//testing/4/SRPMS//firefox-1.0.6-0.1.fc4.src.rpm
...

i.e., it's sending the notification mail before it actually pushes the files?
Comment 3 Bill Nottingham 2005-07-18 20:03:14 EDT
It also appears to run yum-arch/createrepo multiple times for the same repository.
Comment 4 Luke Macken 2005-07-18 20:49:29 EDT
This issue should be fixed.

Note You need to log in before you can comment on or make changes to this bug.