Bug 163338 - kernel panic in acpi_pci_root_add, process: swapper
kernel panic in acpi_pci_root_add, process: swapper
Status: CLOSED DUPLICATE of bug 163337
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-15 07:09 EDT by Karsten Weiss
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 11:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Weiss 2005-07-15 07:09:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.7.8-1.1.3.1

Description of problem:
We are getting the following kernel panic early during boot:

Unable to handle kernel NULL pointer dereference at 0000000000000002 RIP:
<ffffffff80241567>{acpi_pci_root_add+296}
PML4 7fdcc067 PGD 0
Oops: 0000 [1]
CPU 0
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.9-11.EL
RIP: 0010:[<ffffffff80241567>] <ffffffff80241567>{acpi_pci_root_add+296}
RSP: 0018:000001007ff83e08  EFLAGS: 00010206
RAX: 0000000000ff0002 RBX: 000001007fdbb2c0 RCX: ffffffff804d478c
RDX: 0000000000000002 RSI: 0000000000000001 RDI: 0000000000000000
RBP: 0000000000000000 R08: 0000000000000000 R09: 000001007ffde828
R10: 0000000000000000 R11: 0000000000000000 R12: 00000100065a6c00
R13: ffffffff80432320 R14: 0000000000000000 R15: 0000010037ff0f00
FS:  0000000000000000(0000) GS:ffffffff8051e980(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 0000000000000002 CR3: 0000000000101000 CR4: 00000000000006e0
Process swapper (pid: 1, threadinfo 000001007ff82000, task 000001007ff81110)
Stack: 000000000000001a 0000000000000000 0000000000000000 00000000000000ff
       ffffffff80431d00 00000100065a6c00 ffffffff80431d00 ffffffff80245f64
       ffffffff80431d00 00000100065a6c00
Call Trace:<ffffffff80245f64>{acpi_bus_driver_init+49} <ffffffff802471be>{acpi_bus_add+2715}
       <ffffffff80226639>{acpi_os_wait_semaphore+133} <ffffffff8023c7e4>{acpi_ut_acquire_mutex+114}
       <ffffffff80539506>{acpi_scan_init+450} <ffffffff8010c3d9>{init+336}
       <ffffffff80111373>{child_rip+8} <ffffffff8010c289>{init+0}
       <ffffffff8011136b>{child_rip+0}

Code: 48 8b 02 0f 18 08 48 81 fa 10 1e 43 80 74 68 8b 43 18 39 42
RIP <ffffffff80241567>{acpi_pci_root_add+296} RSP <000001007ff83e08>
CR2: 0000000000000002
 <0>Kernel panic - not syncing: Oops

The system is a HP xw9300 Dual-Opteron workstation with 4 GB RAM, NVIDIA
QuadroFX 3400, LSI Logic 53c1030, System bios v1.21 786B9

The system crashes with a smp kernel because of Bug #160135 (with
and without acpi=off - please see my oopses there). With a uni-processor
kernel it only boots with the kernel argument apci=off. Without
it we get the oops above.


Version-Release number of selected component (if applicable):
kernel-2.6.9-11.EL

How reproducible:
Always

Steps to Reproduce:
1. Boot uni-processor kernel-2.6.9-11.EL (without acpi=off)
2.
3.
  

Actual Results:  oops

Expected Results:  no kernel panic

Additional info:

Because of this bug and #160135 we currently are only able to use a single
CPU and no ACPI on this workstation.
Comment 1 Suzanne Hillman 2005-07-15 11:07:35 EDT

*** This bug has been marked as a duplicate of 163337 ***

Note You need to log in before you can comment on or make changes to this bug.