Bug 1633425 - Need regression jobs to build with python version detection
Summary: Need regression jobs to build with python version detection
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-27 00:11 UTC by Shyamsundar
Modified: 2018-10-03 07:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-03 07:41:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2018-09-27 00:11:27 UTC
Description of problem:

The issue that we need to address is,
- Build with the right python version (or shebangs) in the regression jobs
- Build with the right python version for the various distributions

Currently, with the auto correction of python shebangs in configure, the dist packages get bundled with python2 shebangs, whereas this decision needs to be postponed to when packages are built for a distribution.

The above change is addressed with this commit: https://review.gluster.org/c/glusterfs/+/21266

The above change now runs with py3 shebangs even on Cent7 regression machines (idk why that works).

To get this corrected and to run with right python versions and to also enable testing py2 backward compatability (as that is what we are claiming for our python code), we need to get a configure option back into the configure.ac.

This new option will,
- Be off by default (so all shebangs remain py3)
- Should be turned on to detect and hence correct the py shebangs in the python files

The regression jobs hence, should build with this new option enabled, and possibly handle failures till the option is actually available (as Nigel pointed out in a conversation).

This bug is to track the above request (i.e changing the regression jobs to handle the new option).

I think we should call the option "--enable-py-version-correction" (if such long options are permissible. Other nicer verbiage welcome.

Comment 1 Nigel Babu 2018-10-03 07:41:06 UTC
So, the patch in question is merged and we did not add a new option. The tests pass nonetheless because we call python path/to/script.


I'm going to close this bug as I don't think there is an infra action left. Feel free to re-open if you think otherwise.


Note You need to log in before you can comment on or make changes to this bug.