Bug 16335 - Kernel 2.2.16-21 problems...
Kernel 2.2.16-21 problems...
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-16 09:26 EDT by Sammy
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 09:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2000-08-16 09:26:14 EDT
Here are some of the things I noticed:

1. The changelog sais 3c90x driver is 1.0.0i but it is still 1.0.0d
   not the latest.

2. Kernel does not compile if agp support is built into the kernel
   (not as a module). The Makefile looks for agpgart.o and cannot
   find it and fails.

3. What is the deal with the headers? I figured out that the system
   includes from kernel-headers-2.4.0-0.21 should be saperate from
   the includes files /usr/src/linux/include/linux.....is this a new
   convention? I was trying to compile NVIDIA drivers and of course
   they fail when they call /usr/include/linux/modversions.h....
   there should be a longer explanation and instructions when a
   makefile calls it including what gcc flags to use to achieve this
   (some of us are not experts).
Comment 1 Michael K. Johnson 2000-08-16 12:32:00 EDT
1 is known and will be fixed
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=12987

2 is known and won't be fixed for the next release unless
someone comes up with a patch that doesn't break dynamic
compiling in time.
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=13424

3 is following Linus's orders

Because you submitted three bugs in one report I can't close
this as a duplicate of either of the two that it duplicates,
so I'm going to close it as "notabug" regarding 3...  :-)

Note You need to log in before you can comment on or make changes to this bug.