Bug 1633872 - RPM installs "extract ISO-image" service menu for KDE4 but nothing for KDE 5
Summary: RPM installs "extract ISO-image" service menu for KDE4 but nothing for KDE 5
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libisoburn   
(Show other bugs)
Version: 29
Hardware: x86_64 Linux
unspecified
low
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-27 23:02 UTC by skierpage
Modified: 2018-12-24 01:15 UTC (History)
3 users (show)

Fixed In Version: libisoburn-1.5.0-1.fc28 libisoburn-1.5.0-1.fc29 libisoburn-1.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-12-17 02:27:37 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description skierpage 2018-09-27 23:02:55 UTC
Description of problem:
xorriso subproject of libisoburn adds an Action

Version-Release number of selected component (if applicable): 1.4.8.3.4c29.x86_64

How reproducible: I think every time.

Steps to Reproduce:
1. sudo dnf install xorriso
2. look in /usr/share/kde4/
3. look in /usr/share/kservices5/ServiceMenus/
4. start Dolphin, navigate to a directory with a .iso file

Actual results:
There's a /usr/share/kde4/services/ServiceMenus/xorriso_servicemenu.desktop file but nothing in /usr/share/kservices5/ServiceMenus/. So in the KDE 5 that's been shipped since Fedora 22, there's no Actions menu item in Dolphin for a .iso to 'extract ISO-image here.'

Expected results:
Either remove the kde4 action menu or add it in k5services, as e.g. encryptfile.desktop is in both.

Additional info:
I copied /usr/share/kde4/services/ServiceMenus/xorriso_servicemenu.desktop ~/.local/share/kservices5/ and started Dolphin and right-clicking a .ISO now had a top-level "Xorriso: extract ISO-image here" item., for some reason not in the Action menu.

It's probably redundant because the Dolphin action "Extract archive here" seems to work for a .iso. If you really wanted to add to KDE5, the code is at https://src.fedoraproject.org/rpms/libisoburn/blob/master/f/libisoburn.spec#_108

This is super-low priority, but I learned a bit :-)

Comment 1 Fedora Update System 2018-12-08 20:16:33 UTC
libburn-1.5.0-1.fc29 libisofs-1.5.0-1.fc29 libisoburn-1.5.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-470945e132

Comment 2 Fedora Update System 2018-12-08 20:17:24 UTC
libisofs-1.5.0-1.fc28 libburn-1.5.0-1.fc28 libisoburn-1.5.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b24cf4c8fb

Comment 3 Fedora Update System 2018-12-08 20:18:55 UTC
libburn1-1.5.0-1.el7 libisofs1-1.5.0-1.el7 libisoburn-1.5.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-d2b18aa5f1

Comment 4 Fedora Update System 2018-12-17 02:27:37 UTC
libburn-1.5.0-1.fc28, libisoburn-1.5.0-1.fc28, libisofs-1.5.0-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2018-12-17 19:12:06 UTC
libburn-1.5.0-1.fc29, libisoburn-1.5.0-1.fc29, libisofs-1.5.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2018-12-24 01:15:36 UTC
libburn1-1.5.0-1.el7, libisoburn-1.5.0-1.el7, libisofs1-1.5.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.