Bug 16342 - elm should also do .lock ing
elm should also do .lock ing
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: elm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-16 09:53 EDT by Bill Pemberton
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 10:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Pemberton 2000-08-16 09:53:31 EDT
Elm is configured to only do fcntl() locking.  It should be built to also
do .lock since you can't be sure that everything else dealing with
mailboxes understands fcntl() and only fcntl().
Comment 1 Jeff Johnson 2000-08-16 10:12:58 EDT
Since Red Hat 5.2, all mail user agents do fcntl locking *only*. If you wish to
run elm with,
for example, NFS mounted partions with dot locking, you will have to revert the
change and
recompile the package.
Comment 2 Bill Pemberton 2000-08-16 10:17:37 EDT
The idea that everything does fcntl only is fine, but wrong.  Run procmail -v,
for example, and you'll see that it does both .lock and fcntl.

My concern isn't that things work 'out of the box', my concern is that some one
installs some other package that ONLY does .lock and ends up with a conflict
with elm.
Comment 3 Jeff Johnson 2000-08-16 10:22:33 EDT
Um, I don't disagree, I only provide information :-)

The other package, not elm, should be fixed to do *only* fcnt;l locking.

Note You need to log in before you can comment on or make changes to this bug.