Bug 163428 - Mkinitrd does not work if using it on a reiserfs for running FC4 of a USB 2 drive
Mkinitrd does not work if using it on a reiserfs for running FC4 of a USB 2 d...
Status: CLOSED DUPLICATE of bug 162685
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-16 02:28 EDT by Steve
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 16:54:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve 2005-07-16 02:28:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
After custom installing FC4-with selinux disabled-onto a USB 2 drive and custom partitioning with reiserfs for / (root) and reiserfs for /boot partions, there are problems. Anaconda does not go through an extensive formatting with reiser, it doesn't seem like it formats so the problem may be with Anaconda. Incomparing it with ext3, ext3 does a long formatting process.. Anyway there are no errors from anaconda so I finish the install, and reboot to rescue mode to make the initrd image...
I've tried using reiserfs twice.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
(everytime= 2 times)
1. Custom install FC4-w/o selinux-onto USB 2 drive with reiserfs for the root and boot partitions along with a vfat and swap.
2. Complete the install, reboot in rescue mode using disc 1, say no to initailizing the network and no to mounting fedora instalations
..commands at prompt to for custom initrd image..
mount /dev/sdb2 /mnt/source   --sdb2=root of usb drive
mount /dev/sdb1 /mnt/source/boot
chroot /mnt/source
ls -1 /boot (to get kernel version)
mkinitrd --preload=ehci-hcd --preload=usb-storage --preload=scsi_mod \
--preload=sd_mod /boot/initrd_usb.gz 2.6.11.1-1.1369FC4
unable to stat
I get an error, it says more, but I don't remember.

Expected Results:  I should be able to succesfully use the mkinitrd command. I've tried adding other things to the command like --preload=reiserfs which results in the same mkinitrd error.

Additional info:

Is there something I'm doing wrong? I've tried googling and searching forms such as fedorafor, which I am a member, but I havn't found anything. This is not necessary to fix since I want SELinux and there for will use EXT3-which I am doing right now. However, I would like to test reiserfs.
Comment 1 Steve 2005-07-16 14:14:58 EDT
Oh, I found what the error says, I knew I wrote it down and here is what is says
after issuing the above mkinitrd command:
unable to stat /dev/sdb2 : 2
On another note it creates the initrd_usb.gz anyway, and FC4 doesn't boot after
modifying the grub to use it.
Comment 2 Peter Jones 2006-02-03 16:54:07 EST
Reiserfs is completely unsupported.
Comment 3 Peter Jones 2006-02-03 17:44:01 EST

*** This bug has been marked as a duplicate of 162685 ***

Note You need to log in before you can comment on or make changes to this bug.