Bug 163430 - sound stops working with kernel 2.6.12-1.1372_FC3 sound module snd-emu10k1 soundblaster audigy 2
sound stops working with kernel 2.6.12-1.1372_FC3 sound module snd-emu10k1 so...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2005-07-16 04:41 EDT by Ian Jones
Modified: 2015-01-04 17:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 18:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Jones 2005-07-16 04:41:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-1.3.1

Description of problem:
Having installed the latest kernel patches vmlinuz-2.6.12-1.1372_FC3 the sound stopped working. The volume control on gnome panel behaved oddly, reverting to its original position when I tried to change it.

Reverting to  2.6.11-1.35_FC3 cured the problem (for me)

cat /etc/modprobe.conf
# Note: for use under 2.4, changes must also be made to modules.conf!
alias eth0 natsemi
alias usb-controller uhci-hcd
alias ieee1394-controller ohci1394
alias snd-card-0 snd-emu10k1
install sound-slot-0 /sbin/modprobe --first-time --ignore-install sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove sound-slot-0



Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Didn't try

Steps to Reproduce:
1. You need a soundblaster audigy 2, an amd athlon 1700, gigabyte motherboard
2. install the latest kernel 2.6.12 and go to the bbc website and try to listen to something
3.
  

Actual Results:  no sound, volume control behaving oddly

Additional info:
Comment 1 Ian Jones 2005-07-16 06:03:32 EDT
I have just booted this kernel again and tried playing an mp3 with xmms. The
same problem occured: The volume control on the panel is at zero, and when I
move it up it springs back to zero again. Using gnome panel 2.8.1
Comment 2 rhbugz 2005-07-22 02:32:55 EDT
If for no other reason than another data point, I am having the same problem (no
sound) with a "SB Live" card and the 2.6.12-1.1372_FC3 kernel. Intel P4 system with:

[snip]

[root@hellcat ~]# cat /proc/asound/cards
0 [Unknown        ]: EMU10K1 - SB Live [Unknown]
                     SB Live [Unknown] (rev.10, serial:0x80221102) at 0xd880, irq 9
[root@hellcat ~]# cat /etc/modprobe.conf
alias eth0 dmfe
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias char-major-195* nvidia

[snip]

As noted in comment 0, sound works fine with the 2.6.11-1.35_FC3 kernel.
Comment 3 Leigh L. Klotz, Jr. 2005-08-08 02:12:13 EDT
I also have noticed problems with the emu10k1, and could get no mic input.
I noticed that the alsamixer and Gnome Volume Control 2.8.0 no longer listed
"Mic boost (+20db)" as part of the controls.  
Going back to 2.6.11-1.35_FC3 Kernel fixed it.
No amount of futzing with modules modprobe.conf would fix it.
$ cat /proc/asound/cards
0 [Audigy         ]: Audigy - Sound Blaster Audigy
                     Sound Blaster Audigy (rev.3, serial:0x511102) at 0xd400, irq 11
Comment 4 jim 2005-08-10 22:17:58 EDT
I'm also  having the same issue.    
[peggy@fedorajim ~]$ rpm -q kernel
kernel-2.6.11-1.14_FC3
kernel-2.6.11-1.27_FC3
kernel-2.6.11-1.35_FC3
kernel-2.6.12-1.1372_FC3

The only kernel that plays sound is kernel-2.6.11-1.27_FC3 
Since this is my wifes PC and she likes to listen to music all the time I have
had to edit grub to boot to this kernel only.   

[peggy@fedorajim ~]$ cat /etc/modprobe.conf
alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
alias char-major-81 bttv
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

The volume control on the panel is at zero, and when I
move it up it springs back to zero again.

[peggy@fedorajim ~]$ rpm -qa | grep alsa
alsa-driver-1.0.9rf-39.rhfc3.at
alsa-lib-devel-1.0.6-8.FC3
alsa-kmdl-2.6.11-1.14_FC3-1.0.8-36.rhfc3.at
alsa-utils-1.0.6-3
alsa-lib-1.0.6-8.FC3
alsa-kmdl-2.6.12-1.1372_FC3-1.0.9rf-39.rhfc3.at

Could the alsa drive be causing the issue?  


Comment 5 Dave Jones 2005-08-11 02:27:09 EDT
the alsa userspace is quite closely tied to the kernel side.  You have 1.0.9
kernel modules, and 1.0.6 userspace, so quite likely this is problematic.
Try and reproduce with all the rhfc3.at alsa rpms removed, and using just the
ones from FC3 updates
Comment 6 rhbugz 2005-08-11 02:32:17 EDT
(In reply to comment #5)
> Try and reproduce with all the rhfc3.at alsa rpms removed, and using just the
> ones from FC3 updates

I have only the FC3 rpms and still experience the problem.

[mark@hellcat ~]$ rpm -qa | grep -i alsa
alsa-lib-1.0.6-8.FC3
alsa-lib-devel-1.0.6-8.FC3
alsa-utils-1.0.6-3
Comment 7 Ian Jones 2005-08-11 14:27:45 EDT
I too have only fedora alsas. If the problem is the mixer then presumably using
a different mixer, i.e. the consol based one (alsamixer), would fix it? I will
try it a bit later.

# rpm -qa | grep -i alsa
alsa-lib-devel-1.0.6-8.FC3
alsa-utils-1.0.6-3
alsa-lib-1.0.6-8.FC3
Comment 8 Leigh L. Klotz, Jr. 2005-08-11 14:33:20 EDT
I get identical results to Reib (works with 2.6.11-1.35_FC3 but fails with
2.6.12-1.1372_FC3 as reported in #4 above) with regard to packages.  Yum pointed
at the Fedora repositories shows no later version than what I have, save for the
 debuginfo package I have never installed.  Could this be a yum dependency or
repository problem with FC3 updates?

$ rpm -qa | grep -i alsa
alsa-utils-1.0.6-3
alsa-lib-1.0.6-8.FC3
alsa-lib-devel-1.0.6-8.FC3
$ uname -r
2.6.11-1.35_FC3

$ yum list alsa\*
Installed Packages
alsa-lib.i386                            1.0.6-8.FC3            installed
alsa-lib-devel.i386                      1.0.6-8.FC3            installed
alsa-utils.i386                          1.0.6-3                installed
Available Packages
alsa-lib-debuginfo.i386                  1.0.6-8.FC3            updates-released

Comment 9 Ian Jones 2005-08-11 14:41:30 EDT
I have just booted the latest kernel and sound is now working. I didn't even use
the consol mixer. I am at a loss to explain why, unless it has been fixed by
some FC3 update which went in since I raised the bug.
Comment 10 rhbugz 2005-09-27 01:55:17 EDT
I was able to get things working too with 2.6.12-1.1378_FC3 kernel, but only
after one magical step:

[root@hellcat ~]# system-config-soundcard

I have no idea what this utility does ... well, other than making sound work.

Note You need to log in before you can comment on or make changes to this bug.