Bug 1634386 - Even cannot reach grub menu but show recovery blue screen
Summary: Even cannot reach grub menu but show recovery blue screen
Keywords:
Status: CLOSED DUPLICATE of bug 1631989
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-09-30 12:21 UTC by Mamoru TASAKA
Modified: 2018-10-02 15:49 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-02 15:49:52 UTC


Attachments (Terms of Use)
recovery screen after pressing power button (3.53 MB, image/jpeg)
2018-09-30 12:21 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2018-09-30 12:21:07 UTC
Created attachment 1488546 [details]
recovery screen after pressing power button

Description of problem:
After upgrading from Fedora 28 to Fedora 29, booting cannot even reach grub2 menu, but only shows "Recovery" blue screen.

Version-Release number of selected component (if applicable):
grub2-common-1:2.02-59.fc29 
grub2-efi-x64-modules-1:2.02-59.fc29 
grub2-pc-modules-1:2.02-59.fc29 
grub2-efi-x64-1:2.02-59.fc29 
grub2-pc-1:2.02-59.fc29 
grub2-tools-1:2.02-59.fc29 
grub2-tools-efi-1:2.02-59.fc29 
grub2-tools-extra-1:2.02-59.fc29 
grub2-tools-minimal-1:2.02-59.fc29 
efibootmgr-16-4.fc29
shim-x64-15-5 
efi-filesystem-3-3.fc29

How reproducible:
100%

Steps to Reproduce:
1. Upgrade to the above packages
2. boot
3.

Actual results:
Does not even reach grub2 menu, just showing recovery screen as attached

Expected results:
Working packages:

grub2-common-2.02-38.fc28.noarch.rpm
grub2-efi-x64-2.02-38.fc28.x86_64.rpm
grub2-efi-x64-modules-2.02-38.fc28.noarch.rpm
grub2-pc-2.02-38.fc28.x86_64.rpm
grub2-pc-modules-2.02-38.fc28.noarch.rpm
grub2-tools-2.02-38.fc28.x86_64.rpm
grub2-tools-efi-2.02-38.fc28.x86_64.rpm
grub2-tools-extra-2.02-38.fc28.x86_64.rpm
grub2-tools-minimal-2.02-38.fc28.x86_64.rpm
efibootmgr-16-2.fc28.x86_64.rpm
shim-x64-15-2.x86_64.rpm


Additional info:
lshw:
    description: Notebook
    product: HP Spectre x360 Convertible (T0Y39PA#ABJ)
    vendor: HP
    version: Chassis Version
    serial: 5CD6413LH3
    width: 64 bits
    capabilities: smbios-2.8 dmi-2.8 smp vsyscall32

Maybe related to (or dup? or) bug 1626862

Comment 1 Fedora Blocker Bugs Application 2018-09-30 12:27:18 UTC
Proposed as a Blocker for 29-final by Fedora user mtasaka using the blocker tracking app because:

 All release-blocking images must boot in their supported configurations.

Comment 2 Adam Williamson 2018-09-30 16:28:23 UTC
That's a Windows screen, by the looks of it. Is this a dual-boot install? How did you initially install the OSes on it?

Comment 3 František Zatloukal 2018-09-30 17:03:03 UTC
Adam, this is looks like a dup of my bug 1626862 (I've experienced the same outcome after upgrading to Fedora 29).

Apparently, some UEFIs try (but fail) to boot something else if default option does not work (which is the case if user had GRUB as default and it became broken by upgrading to fc29 grub packages).

mtasaka, does rolling back to FC28 versions fix the issue for you? Does booting Windows directly from UEFI Boot Menu work?

Comment 4 Mamoru TASAKA 2018-09-30 22:58:13 UTC
Well, initially this was Windows 10 machine, but (I thought) I (almost?) deleted it by install Fedora:

# LC_ALL=C fdisk -l
Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: B16244E8-A000-4051-859C-1E1EF731A5C6

Device        Start       End   Sectors   Size Type
/dev/sda1      2048    534527    532480   260M EFI System
/dev/sda2    534528   2631679   2097152     1G EFI System
/dev/sda3   2631680  13117439  10485760     5G Linux filesystem
/dev/sda4  13117440 500117503 487000064 232.2G Linux LVM

And /dev/sda2 is mounted as /boot/efi . /dev/sda1 is perhaps some garbage (some Windows file left? maybe some backup files are left on /dev/sda1)


> mtasaka, does rolling back to FC28 versions fix the issue for you? 
Yes, as I wrote in comment 0 .

> Does booting Windows directly from UEFI Boot Menu work?
Well, as I said (I think) I deleted Windows 10, however some backup files may be left on /dev/sda1 .

Comment 5 Peter Jones 2018-10-01 14:54:37 UTC
Is it possible for you to attach program.log from the installed image?  My thinking here is that somehow efibootmgr failed (or the firmware didn't honor it), and the firmware is running the windows boot recovery from the "first" EFI System Partition.

Comment 6 Adam Williamson 2018-10-01 17:09:24 UTC
Mamoru: that is, try and mount the installed system, and attach the file /var/log/anaconda/program.log from it.

However...pjones, Mamoru says this broke "After upgrading from Fedora 28 to Fedora 29". That implies it was working fine after it was first installed. So I don't think program.log is going to be relevant? It seems like somehow F29 grub2 dies on this 'multiple ESP' situation, but F28 grub2 is OK with it.

I can try reproducing this in a VM today...

Comment 7 Adam Williamson 2018-10-01 19:40:01 UTC
Well, I kinda tried to reproduce this by installing F27 and using custom partitioning to create a 260MB /dev/vda1 EFI system partition mounted as '/otherefi', a 1GB /dev/vda2 EFI system partition mounted as /boot/efi , and the rest of the disk as a plain ext4 fs mounted as / . This booted fine with F27. I updated grub packages to the latest F28 stable grub2 - 2.02-38 - and the system continued to boot fine. I then updated grub packages plus dependencies (efi-rpm-macros and grubby) to the latest F29 stable - 2.02-59...and the system *still* boots fine.

So there must be something somehow different to that going on, whether it's the initial deployment or the firmware or what, I'm not sure. I was testing in a qemu VM with firmware from edk2-ovmf-20180815gitcb5f4f45ce-1.fc29.noarch .

Comment 8 Geoffrey Marr 2018-10-01 19:49:27 UTC
Discussed during the 2018-10-01 blocker review meeting: [1]

The decision to delay the classification of this as a blocker bug was made as we are homing in on what's going on in this case (likely to do with multiple ESPs), but still need a bit more info to determine how significant it's likely to be. We will try to reproduce this independently and investigate further.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2018-10-01/f29-blocker-review.2018-10-01-16.00.txt

Comment 9 Mamoru TASAKA 2018-10-02 00:46:00 UTC
Well, as Adam said, I upgraded from F-28 to F-29 and program.log (by anaconda, okay?) is much older, is that okay?

Anyway once showing (perhaps) related part from (rather old) /var/log/anaconda/program.log:

21:18:54,432 INFO program: Running... new-kernel-pkg --rpmposttrans 4.8.6-300.fc25.x86_64
21:19:26,800 INFO program: Initializing machine ID from random generator.
21:19:26,800 DEBUG program: Return code: 0
21:19:26,985 INFO program: Running... efibootmgr
21:19:27,007 INFO program: BootCurrent: 0006
21:19:27,008 INFO program: Timeout: 0 seconds
21:19:27,008 INFO program: BootOrder: 0004,0005,0006
21:19:27,009 INFO program: Boot0004* Windows Boot Manager
21:19:27,009 INFO program: Boot0005* Solid State Disk
21:19:27,009 INFO program: Boot0006* USB Drive (UEFI) - TEAC DV-W28S-W L.0A
21:19:27,010 DEBUG program: Return code: 0
21:19:27,011 INFO program: Running... efibootmgr -c -w -L Fedora -d /dev/sda -p 2 -l \EFI\fedora\shim.efi
21:19:27,039 INFO program: BootCurrent: 0006
21:19:27,039 INFO program: Timeout: 0 seconds
21:19:27,040 INFO program: BootOrder: 0000,0004,0005,0006
21:19:27,040 INFO program: Boot0004* Windows Boot Manager
21:19:27,040 INFO program: Boot0005* Solid State Disk
21:19:27,040 INFO program: Boot0006* USB Drive (UEFI) - TEAC DV-W28S-W L.0A
21:19:27,040 INFO program: Boot0000* Fedora
21:19:27,040 DEBUG program: Return code: 0
21:19:27,042 INFO program: Running... grub2-set-default 0
21:19:27,070 DEBUG program: Return code: 0
21:19:27,071 INFO program: Running... grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
21:19:29,488 INFO program: Generating grub configuration file ...
21:19:29,489 INFO program: Found linux image: /boot/vmlinuz-4.8.6-300.fc25.x86_64
21:19:29,489 INFO program: Found initrd image: /boot/initramfs-4.8.6-300.fc25.x86_64.img
21:19:29,489 INFO program: Found linux image: /boot/vmlinuz-0-rescue-4444d860031845eb9bea12a137c4c220
21:19:29,489 INFO program: Found initrd image: /boot/initramfs-0-rescue-4444d860031845eb9bea12a137c4c220.img
21:19:29,489 INFO program: Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
21:19:29,489 INFO program: done

And currently working efibootmgr-16-2.fc28.x86_64 reports:
# efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0004,0005,0007,0008
Boot0000* Fedora	HD(2,GPT,3e92f9ad-b65a-4efd-b290-500cae67462e,0x82800,0x200000)/File(\EFI\fedora\shim.efi)
Boot0004* Windows Boot Manager	HD(1,GPT,25f1da69-d7d0-4dd5-9952-9bb55c7f9705,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...9................
Boot0005* Solid State Disk	PciRoot(0x0)/Pci(0x17,0x0)/Sata(1,65535,0)/HD(1,GPT,25f1da69-d7d0-4dd5-9952-9bb55c7f9705,0x800,0x82000)..BO
Boot0007* Solid State Disk	PciRoot(0x0)/Pci(0x17,0x0)/Sata(1,65535,0)/HD(2,GPT,3e92f9ad-b65a-4efd-b290-500cae67462e,0x82800,0x200000)..BO
Boot0008* USB Drive (UEFI) - TEAC DV-W28S-W L.0A	PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/CDROM(1,0x712d,0x4664)..BO

Comment 10 Mamoru TASAKA 2018-10-02 00:48:18 UTC
By the way when I use linux-host VirtualBox-5.2.18-1.fc29.x86_64 and use Fedora-Workstation-Live-x86_64-29-20180929.n.0.iso as guest, it boots fine (on VM). So maybe this is real-machine specific??

Comment 11 Mamoru TASAKA 2018-10-02 01:05:45 UTC
Oh, after upgrading to shim-x64-15-5.x86_64, (and this also upgrades efibootmgr to 16-4.fc29)

# rpm -ql shim-x64-15-5.x86_64
/boot/efi/EFI/BOOT/BOOTX64.EFI
/boot/efi/EFI/BOOT/fbx64.efi
/boot/efi/EFI/fedora/BOOTX64.CSV
/boot/efi/EFI/fedora/mmx64.efi
/boot/efi/EFI/fedora/shimx64-fedora.efi
/boot/efi/EFI/fedora/shimx64.efi

So there is no /boot/efi/EFI/fedora/shim.efi . but efibootmgr to 16-4.fc29 still says:
# efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0004,0005,0007,0008
Boot0000* Fedora	HD(2,GPT,3e92f9ad-b65a-4efd-b290-500cae67462e,0x82800,0x200000)/File(\EFI\fedora\shim.efi) <=======================
Boot0004* Windows Boot Manager	HD(1,GPT,25f1da69-d7d0-4dd5-9952-9bb55c7f9705,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...9................
Boot0005* Solid State Disk	PciRoot(0x0)/Pci(0x17,0x0)/Sata(1,65535,0)/HD(1,GPT,25f1da69-d7d0-4dd5-9952-9bb55c7f9705,0x800,0x82000)..BO
Boot0007* Solid State Disk	PciRoot(0x0)/Pci(0x17,0x0)/Sata(1,65535,0)/HD(2,GPT,3e92f9ad-b65a-4efd-b290-500cae67462e,0x82800,0x200000)..BO
Boot0008* USB Drive (UEFI) - TEAC DV-W28S-W L.0A	PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/CDROM(1,0x712d,0x4664)..BO

So maybe this is the reason??

For reference:
# rpm -qlp shim-x64-15-2.x86_64.rpm
/boot/efi
/boot/efi/EFI
/boot/efi/EFI/BOOT
/boot/efi/EFI/BOOT/BOOTX64.EFI
/boot/efi/EFI/BOOT/fallback.efi
/boot/efi/EFI/BOOT/fbx64.efi
/boot/efi/EFI/fedora
/boot/efi/EFI/fedora/BOOT.CSV
/boot/efi/EFI/fedora/BOOTX64.CSV
/boot/efi/EFI/fedora/MokManager.efi
/boot/efi/EFI/fedora/mmx64.efi
/boot/efi/EFI/fedora/shim.efi
/boot/efi/EFI/fedora/shimx64-fedora.efi
/boot/efi/EFI/fedora/shimx64.efi

Comment 12 Mamoru TASAKA 2018-10-02 01:15:11 UTC
So now I additionally installed shim-ia32-15-5.x86_64, and now my machine boots fine!!!

Comment 13 Mamoru TASAKA 2018-10-02 03:34:12 UTC
And it seems that other people are reporting the same issue:

https://bugzilla.redhat.com/show_bug.cgi?id=1631989

Comment 14 Christian Stadelmann 2018-10-02 08:43:04 UTC
I see the same issue: After a system upgrade from F28 to F29, my system does not boot any more. I have not reported the issue because I had no time nor data to dig deep into what caused the issue.

(In reply to Mamoru TASAKA from comment #12)
> So now I additionally installed shim-ia32-15-5.x86_64, and now my machine
> boots fine!!!

Same workaround here. The system needs shim-ia32 to reach grub2 boot menu. This was different on Fedora 28 where I did not have shim-ia32 installed.

Comment 15 Adam Williamson 2018-10-02 15:49:52 UTC
OK, yeah. Let's make this a dupe of that. Looks like the issue's actually quite straightforward...

*** This bug has been marked as a duplicate of bug 1631989 ***


Note You need to log in before you can comment on or make changes to this bug.