Bug 163460 - Installation failed on RAID setup (GRUB error 15 and failed to mount /)
Installation failed on RAID setup (GRUB error 15 and failed to mount /)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-17 09:58 EDT by rh
Modified: 2008-07-24 16:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhel4u7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:58:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rh 2005-07-17 09:58:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050524 Firefox/1.0 (Ubuntu package 1.0.2 MFSA2005-44)

Description of problem:
I installed a machine with RHEL4 ES on a machine with a pair of IDE discs that I configured using software RAID, the install appeared successful until the reboot where I hit a GRUB error 15; having fixed that it then had problems mounting the root filesystem RAID.

The discs had old installs on previously, so the first thing I did in the graphical installer was delete all partitions; the pair of discs were not identical but close in size.

I created three pairs of partitions - using the individual partition creation in the graphical installer, assigning each one as RAID;
    one for /boot (250MB)
    one for swap  (2GB)
    one for /     (about 34GB)

The partitions were created with fixed sizes.
I then went and told it to create three mirrored RAIDs.

The boot gave a GRUB error 15 (after or at loading stage 1.5?) - at that point I
booted off the install CD, used mdadm to bring up the RAID and then used the grub command line and grub's   'setup' command to reinstall grub; so that fixed that. (I didn't change the initrd or menu.lst file - so all the initrd setup and root fs paths were as produced by the installer).

Now on boot it complained it couldn't mount / ; and looking at the boot messages
I think it had failed to autostart one of the three RAIDs.

Using the rescue mode on the install CD it would give me the option of mounting md1 as the root filesystem, but once selected it would say there was an error and drop me to a shell.  (It listed md1 twice actually for some reason).

It looks like the GUI parttioning had decided to create the partitions on the two discs in opposite orders; i.e. 

  the md0 raid was hda1, hdc1
      md1 raid     hda3, hdc2
      md2 raid     hda2, hdc3

(They were definitely mismatched like this - I'm not sure if it was md1 that
was hda3).

So I attacked it with fdisk and swapped the partition numbering round, and a
few more boots I was OK.

I sugges that autodetection of the RAID for / without any checking that ensures that it finds the right RAID is not robust enough - wouldn't it be better to assemble the / RAID given the unique IDs in the RAID parts so that even if another RAID disappears then at least / is there and you have a bootable system?

Dave

P.S. *please* do something about the 'time left to install' approximation - it is hopelessly optimistic, it spent 2 hours or more at '50 mins remaining'

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 David Tonhofer 2006-08-24 16:46:41 EDT
Just cross-referencing this:

Bug #191449 NEW install grub incorrect when /boot is a RAID1 device
Bug #170575 NEW grub fails on one of two sata disks of raid1 set during i...
>> Bug #163460 NEW Installation failed on RAID setup (GRUB error 15 and fail...
Bug #160563 NEW "grub-install /dev/md0" does not install on second disk i...
Bug #114690 CLOSED/RAWHIDE grub-install won't install to RAID 1
Comment 2 Andy Lindeberg 2008-07-24 16:58:29 EDT
This has been tested with rhel4u7 and the reported bug no longer appears. Please
try installing the latest release to see if it works for you. If you encounter
the problem again, feel free to reopen this bug with the information.

Note You need to log in before you can comment on or make changes to this bug.