Bug 1634831 - clang-analyzer requires Python 2 and Python 3
Summary: clang-analyzer requires Python 2 and Python 3
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: clang
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: serge_sans_paille
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3 PYTHON3-PYTHON2
TreeView+ depends on / blocked
 
Reported: 2018-10-01 18:28 UTC by Miro Hrončok
Modified: 2018-12-12 02:42 UTC (History)
6 users (show)

Fixed In Version: clang-7.0.0-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-12 02:42:10 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2018-10-01 18:28:41 UTC
clang-analyzer-0:7.0.0-1.fc30 requires both Pythons:

$ dnf repoquery --repo=rawhide --requires clang-analyzer | grep python
/usr/bin/python3
python2

This usually indicates a packaging problem.

/usr/bin/scan-view has a Python 3 shebang and thus should run on Python 3.

The Python 2 dependency is most likely bogus.

The specfile says:

# not picked up automatically since files are currently not installed in
# standard Python hierarchies yet
Requires:	python2


There are Python files in /usr/share/scan-view/ - they appear to by Python 2 only.

How is the user supposed to run them? Are they needed? Do they justify the dependency?

Thanks.

Comment 1 serge_sans_paille 2018-11-27 13:32:34 UTC
Should be fixed by https://src.fedoraproject.org/rpms/clang/c/b730992174fb7a6ccf3c466bd09b0921fed25699?branch=master

tstellar had already done the python2 to python3 conversion, the patch foces the use of python3 at build time which prevents python2 from popping up.

Comment 2 Tom Stellard 2018-12-12 02:42:10 UTC
Confirmed fixed in clang-7.0.0-4.fc30.


Note You need to log in before you can comment on or make changes to this bug.