Bug 1635041 (CVE-2018-17582) - CVE-2018-17582 tcpreplay: heap-based buffer over-read in the get_next_packet() in send_packets.c
Summary: CVE-2018-17582 tcpreplay: heap-based buffer over-read in the get_next_packet(...
Status: CLOSED UPSTREAM
Alias: CVE-2018-17582
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20180924,reported=2...
Keywords: Security
Depends On: 1635042 1635043
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-01 21:32 UTC by Laura Pardo
Modified: 2019-06-10 10:38 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-06-10 10:38:57 UTC


Attachments (Terms of Use)

Description Laura Pardo 2018-10-01 21:32:38 UTC
A flaw was found in tcpreplay v4.3.0. A heap-based buffer over-read in the get_next_packet() function in the send_packets.c file due to the use of the memcpy() function unsafely to copy sequences from the source buffer pktdata to the destination (*prev_packet)->pktdata. This will result in a Denial of Service (DoS) and potentially Information Exposure when the application attempts to process a file.


References:
https://github.com/appneta/tcpreplay/issues/484 	
https://github.com/SegfaultMasters/covering360/blob/master/tcpreplay

Comment 1 Laura Pardo 2018-10-01 21:33:10 UTC
Created tcpreplay tracking bugs for this issue:

Affects: epel-all [bug 1635043]
Affects: fedora-all [bug 1635042]

Comment 2 Product Security DevOps Team 2019-06-10 10:38:57 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.