SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 1635233 - cassandra: failed to start service
Summary: cassandra: failed to start service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cassandra
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jančo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-02 12:38 UTC by Jakub Jančo
Modified: 2018-11-02 19:21 UTC (History)
2 users (show)

Fixed In Version: cassandra-3.11.1-10.fc27 cassandra-3.11.1-10.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 17:10:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Jakub Jančo 2018-10-02 12:38:46 UTC
Description of problem:
Cassandra fails to start service. Without installing package cassandra, there is missing dependency guava20.

Version-Release number of selected component (if applicable):
3.11.1-7

How reproducible:
always

Steps to Reproduce:
1. yum install cassandra-server
2. systemctl start cassandra

Actual results:
ndra[1354]: Exception in thread "main" java.lang.NoClassDefFoundError: com/google/common/collect/ImmutableSet
ndra[1354]:         at org.apache.cassandra.service.StartupChecks.<clinit>(StartupChecks.java:437)
ndra[1354]:         at org.apache.cassandra.service.CassandraDaemon.<init>(CassandraDaemon.java:168)
ndra[1354]:         at org.apache.cassandra.service.CassandraDaemon.<init>(CassandraDaemon.java:162)
ndra[1354]:         at org.apache.cassandra.service.CassandraDaemon.<clinit>(CassandraDaemon.java:151)
ndra[1354]: Caused by: java.lang.ClassNotFoundException: com.google.common.collect.ImmutableSet
ndra[1354]:         at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
ndra[1354]:         at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
ndra[1354]:         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
ndra[1354]:         at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
ndra[1354]:         ... 4 more

Comment 1 Fedora Update System 2018-10-03 14:50:41 UTC
cassandra-3.11.1-9.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-911354f481

Comment 2 Fedora Update System 2018-10-03 14:50:51 UTC
cassandra-3.11.1-9.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c148d96ddc

Comment 3 Fedora Update System 2018-10-04 11:32:15 UTC
cassandra-3.11.1-10.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-705e42b25b

Comment 4 Fedora Update System 2018-10-04 11:32:27 UTC
cassandra-3.11.1-10.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1783bc8921

Comment 5 Fedora Update System 2018-10-05 18:06:29 UTC
cassandra-3.11.1-10.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1783bc8921

Comment 6 Fedora Update System 2018-10-05 19:31:07 UTC
cassandra-3.11.1-10.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-705e42b25b

Comment 7 Fedora Update System 2018-11-01 17:10:06 UTC
cassandra-3.11.1-10.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-11-02 19:21:55 UTC
cassandra-3.11.1-10.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.