Bug 163526 - QLogic failover doesn't work with HP EVA3000 in AA config
QLogic failover doesn't work with HP EVA3000 in AA config
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-07-18 12:34 EDT by Simon Matter
Modified: 2010-10-21 23:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: U6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-06 07:48:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Spec file for updated QLogic driver (1.19 KB, patch)
2005-07-18 12:37 EDT, Simon Matter
no flags Details | Diff
The QLogic driver version 7.05.00 as a patch (832.70 KB, patch)
2005-07-18 12:39 EDT, Simon Matter
no flags Details | Diff

  None (edit)
Description Simon Matter 2005-07-18 12:34:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

Description of problem:
The failover which is built into the QLogic driver used in kernel-smp-2.4.21-32.0.1.EL doesn't work in combination with a redundant HP EVA3000 in active/active failover configuration. Multipathing works on the hosts FC connection, however a failover on the HSV controllers is not handled properly.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Configure the qla2300 module for failover
2. reboot the first HSV controller, then reboot the second
3. check the disks presented

Actual Results:  Sometimes you still have access to the disks, sometimes not. In our case one or two out of three servers were always disconnected. Not nice for the mounted filesystems.

Expected Results:  The failover should have worked and the disks should still be visible.

Additional info:

The current RHEL3 U5 kernel doesn't include the latest QLogic driver which has special support for HP EVA failover. The version of the qla2300 module included is 7.01.01, while the current which has worked perfectly in out tests is 7.05.00, with adapter firmware 3.03.11.
I have created updated kernel rpms which have worked fine in our tests and it seems a good reason to include the updated driver into the next kernel update. I will attach the patches I used to build the new packages.
Comment 1 Simon Matter 2005-07-18 12:37:24 EDT
Created attachment 116876 [details]
Spec file for updated QLogic driver
Comment 2 Simon Matter 2005-07-18 12:40:00 EDT
Created attachment 116877 [details]
The QLogic driver version 7.05.00 as a patch

This patch simply includes the sources for the QLogic driver the patch form. It
has been prepared exactly the same way like the original patch which is version
Comment 4 Tom Coughlan 2005-10-17 10:26:27 EDT
Please test with the updated driver in U6. Let us know the results. 
Comment 6 Simon Matter 2005-12-06 01:47:10 EST
Unfortunately I'm unable to test the failover with U6 kernels because I can't
reboot the HSV controllers of our HP EVA storage which are used by a number of
other servers which don't survive a controller reboot. However I did test my own
kernel whith updated QLogic driver driver and it worked fine. Now, the U6 kernel
contains exactly the same driver as I tested so I guess everything should be fine.
We will test the QLogic failover on our EVA3000 once all other non Linux servers
attached to it have been fixed, which may take some more time.
Comment 7 Tom Coughlan 2005-12-06 07:48:32 EST
Sounds like this is fixed in U6. Please re-open if this turns out not to be the
Comment 8 Ernie Petrides 2005-12-06 18:24:15 EST
A fix for this problem was committed to the RHEL3 U6 patch pool
on 15-Jul-2005 (in kernel version 2.4.21-32.12.EL).

The U6 kernel was release as version 2.4.21-37.EL, and here's the
associated message from the Errata System:

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

Comment 9 Simon Matter 2006-01-30 02:10:15 EST
I have finally been able to test the QLogic failover on our EVA3000 with
kernel-2.4.21-37.0.1.EL and it has worked fine.

Note You need to log in before you can comment on or make changes to this bug.