Bug 1635314 - [ERROR]: The python-notario library is missing. Please install it on the node
Summary: [ERROR]: The python-notario library is missing. Please install it on the node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 3.2
Assignee: Ken Dreyer (Red Hat)
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks: 1553640 1630975
TreeView+ depends on / blocked
 
Reported: 2018-10-02 15:23 UTC by Filip Hubík
Modified: 2019-01-03 19:02 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.0-0.1.beta3.el7cp Ubuntu: ceph-ansible_3.2.0~beta5-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/lib/mistral/overcloud/ansible.log (8.70 MB, text/plain)
2018-10-02 15:23 UTC, Filip Hubík
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:15 UTC

Description Filip Hubík 2018-10-02 15:23:49 UTC
Created attachment 1489496 [details]
/var/lib/mistral/overcloud/ansible.log

Description of problem:

As part of OpenStack(OSP) Director 14 deployment, run of ceph-ansible (3.2.0-0.1.beta2.el7cp) fails on error as part of mistral deployment:

[ERROR]: The python-notario library is missing. Please install it on the node\nyou are running ceph-ansible to continue.\nThe python-notario library is missing. Please install it on the node you are running ceph-ansible to continue.", "stderr_lines": ["[DEPRECATION WARNING]: The use of 'static' has been deprecated. Use ", "'import_tasks' for static inclusion, or 'include_tasks' for dynamic inclusion. ", "This feature will be removed in a future release. Deprecation warnings can be ", "disabled by setting deprecation_warnings=False in ansible.cfg.", " [WARNING]: Could not match supplied host pattern, ignoring: agents", " [WARNING]: Could not match supplied host pattern, ignoring: mdss", " [WARNING]: Could not match supplied host pattern, ignoring: rgws", " [WARNING]: Could not match supplied host pattern, ignoring: nfss", " [WARNING]: Could not match supplied host pattern, ignoring: restapis", " [WARNING]: Could not match supplied host pattern, ignoring: rbdmirrors", " [WARNING]: Could not match supplied host pattern, ignoring: iscsigws", " [WARNING]: Could not match supplied host pattern, ignoring: iscsi-gws", "
,,,

2018-10-02 10:49:47,464 p=605 u=mistral |  NO MORE HOSTS LEFT *************************************************************
2018-10-02 10:49:47,464 p=605 u=mistral |  PLAY RECAP *********************************************************************
2018-10-02 10:49:47,465 p=605 u=mistral |  ceph-0                     : ok=109  changed=47   unreachable=0    failed=0
2018-10-02 10:49:47,465 p=605 u=mistral |  compute-0                  : ok=130  changed=61   unreachable=0    failed=0
2018-10-02 10:49:47,465 p=605 u=mistral |  controller-0               : ok=174  changed=84   unreachable=0    failed=0
2018-10-02 10:49:47,465 p=605 u=mistral |  undercloud                 : ok=31   changed=10   unreachable=0    failed=1
2018-10-02 10:49:47,466 p=605 u=mistral |  Tuesday 02 October 2018  10:49:47 -0400 (0:00:19.371)       0:10:17.739 *******
2018-10-02 10:49:47,466 p=605 u=mistral |  ===============================================================================

Version-Release number of selected component (if applicable):
OSP14, ceph-ansible-3.2.0-0.1.beta2.el7cp.noarch

How reproducible:
1. Deploy OSP14 using InfraRed, topology 1:1:1:1
2. Overcloud deployment fails on mistral step mentioned, ceph-ansible related

Full /var/lib/mistral/overcloud/ansible.log log attached.

Comment 4 Filip Hubík 2018-10-02 15:49:09 UTC
Also, this issue affects OSP13 too.

Comment 5 Christina Meno 2018-10-02 16:14:53 UTC
Is this a new dependency in this version for the validate module?
probably OSP doesn’t have it because they haven’t added it to their repo.

Would you please confirm this week?

Comment 6 Andrew Schoen 2018-10-02 16:18:30 UTC
(In reply to Gregory Meno from comment #5)
> Is this a new dependency in this version for the validate module?
> probably OSP doesn’t have it because they haven’t added it to their repo.
> 
> Would you please confirm this week?

Yes, it is a dependency introduced by the validate module in ceph-ansible. I believe Ken is working on getting python-notario built downstream. Ken, can you confirm that's the plan? Thanks.

Comment 7 Ken Dreyer (Red Hat) 2018-10-02 19:19:23 UTC
I failed to synchronize ceph-ansible.spec.in upstream with ceph-ansible.spec downstream for ceph-ansible-3.2.0-0.1.beta2.el7cp.

Upstream we have "Requires: python-notario >=  0.0.13", but we don't have that line downstream, so notario is not in our RHCEPH 3.2 composes, and users don't know to install it.

I'll synchronize ceph-ansible.spec.in upstream with ceph-ansible.spec downstream after Guillaume or Sebastien push the next v3.2 Git tag for ceph-ansible.

Comment 18 errata-xmlrpc 2019-01-03 19:02:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.