Bug 1635598 - python-cups: Remove (sub)packages from Fedora 30+: python2-cups
Summary: python-cups: Remove (sub)packages from Fedora 30+: python2-cups
Keywords:
Status: CLOSED DUPLICATE of bug 1578356
Alias: None
Product: Fedora
Classification: Fedora
Component: python-cups
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PY2REMOVAL
TreeView+ depends on / blocked
 
Reported: 2018-10-03 11:17 UTC by Miro Hrončok
Modified: 2018-10-03 12:32 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-03 12:32:55 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2018-10-03 11:17:04 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-cups were marked for removal:

 * python2-cups

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

Comment 1 Zdenek Dohnal 2018-10-03 12:32:55 UTC
Hi Miro,

I have already open bugzilla for removal. See https://bugzilla.redhat.com/show_bug.cgi?id=1578356 . There were some dependent packages now, but there are none now according repoquery. I'll remove it now.

*** This bug has been marked as a duplicate of bug 1578356 ***


Note You need to log in before you can comment on or make changes to this bug.