Bug 163582 - swap entry in fstab corrupted when swap is installed to md RAID
swap entry in fstab corrupted when swap is installed to md RAID
Status: CLOSED DUPLICATE of bug 159087
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 163584 163585 163586 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-19 03:08 EDT by Anchor Systems Managed Hosting
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-19 11:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anchor Systems Managed Hosting 2005-07-19 03:13:52 EDT
*** Bug 163584 has been marked as a duplicate of this bug. ***
Comment 1 Anchor Systems Managed Hosting 2005-07-19 03:14:29 EDT
*** Bug 163585 has been marked as a duplicate of this bug. ***
Comment 2 Anchor Systems Managed Hosting 2005-07-19 03:15:03 EDT
*** Bug 163586 has been marked as a duplicate of this bug. ***
Comment 3 Anchor Systems Managed Hosting 2005-07-19 03:16:40 EDT
Sorry for the duplicates, there was a problem submitting. Here is the text of
the bug:

I am installing a machine with two SCSI hard drives in RAID1. We create all of
the system partitions on RAID1, and place the swap partition on one of the md
devices. In previous Fedora Core and RHEL releases this has worked fine. In FC4
I check the /etc/fstab file immediately after install but before reboot and see
this entry for the swap partition:

LABEL=Y¥W¥X¥ç¨      swap                    swap    defaults        0 0

After reboot, something decides it is a corrupt entry and removes it, thus
leaving the system after reboot without any swap partition at all. Installing to
a single disk without RAID does not have the same problem. I do notice however
that FC4 is now attempting to "intelligently" label the swap partition so
perhaps the logic behind this naming is at fault.
Comment 4 Chris Lumens 2005-07-19 11:00:20 EDT

*** This bug has been marked as a duplicate of 159087 ***

Note You need to log in before you can comment on or make changes to this bug.