Bug 1635863 - Gluster peer probe doesn't work for IPv6
Summary: Gluster peer probe doesn't work for IPv6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: 4.1
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1664590
TreeView+ depends on / blocked
 
Reported: 2018-10-03 19:24 UTC by Yan
Modified: 2019-03-27 19:40 UTC (History)
2 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1664590 (view as bug list)
Environment:
Last Closed: 2019-01-22 13:48:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21948 None Merged rpc: use address-family option from vol file 2019-01-22 13:48:08 UTC

Description Yan 2018-10-03 19:24:39 UTC
Description of problem:

# gluster peer probe gluster-1
peer probe: failed: Probe returned with Transport endpoint is not connected

Version-Release number of selected component (if applicable):
# gluster peer probe gluster-1
peer probe: failed: Probe returned with Transport endpoint is not connected


How reproducible:
Install 4.1.4 and run gluster peer probe ipv6-peer

Steps to Reproduce:
1. turn on "option transport.address-family inet6" in glusterd.vol
2. Verify the remote peer is ping6-able
3. Run "gluster peer probe"

Actual results:

# gluster peer probe gluster-1
peer probe: failed: Probe returned with Transport endpoint is not connected
# ping6 gluster-1
PING gluster-1(gluster-1 (3010::13:199:0:0:42)) 56 data bytes
64 bytes from gluster-1 (3010::13:199:0:0:42): icmp_seq=1 ttl=64 time=1.54 ms
64 bytes from gluster-1 (3010::13:199:0:0:42): icmp_seq=2 ttl=64 time=0.439 ms


Expected results:
Peer probe should succeeds.

Additional info:

1). Log from glusterd.log

[2018-10-03 19:06:25.009874] I [MSGID: 106487] [glusterd-handler.c:1244:__glusterd_handle_cli_probe] 0-glusterd: Received CLI probe req gluster-1 24007
[2018-10-03 19:06:25.010729] I [MSGID: 106128] [glusterd-handler.c:3635:glusterd_probe_begin] 0-glusterd: Unable to find peerinfo for host: gluster-1 (24007)
[2018-10-03 19:06:25.028897] W [MSGID: 106061] [glusterd-handler.c:3408:glusterd_transport_inet_options_build] 0-glusterd: Failed to get tcp-user-timeout
[2018-10-03 19:06:25.029031] I [rpc-clnt.c:1059:rpc_clnt_connection_init] 0-management: setting frame-timeout to 600
[2018-10-03 19:06:25.033267] E [MSGID: 101075] [common-utils.c:312:gf_resolve_ip6] 0-resolver: getaddrinfo failed (Name or service not known)
[2018-10-03 19:06:25.033366] E [name.c:267:af_inet_client_get_remote_sockaddr] 0-management: DNS resolution failed on host gluster-1
[2018-10-03 19:06:25.033538] I [MSGID: 106498] [glusterd-handler.c:3561:glusterd_friend_add] 0-management: connect returned 0
[2018-10-03 19:06:25.033657] I [MSGID: 106004] [glusterd-handler.c:6382:__glusterd_peer_rpc_notify] 0-management: Peer <gluster-1> (<00000000-0000-0000-0000-000000000000>), in state <Establishing Connection>, has disconnected from glusterd.

2). Peer probe works for ipv4 address with the same config

Comment 1 Yan 2018-10-15 15:33:27 UTC

Please refer: https://bugzilla.redhat.com/show_bug.cgi?id=1609799


Could any one rebuild newer libtirpc and glusterfs with --with-ipv6-default flag to fix the issue?

Comment 2 Worker Ant 2018-12-28 10:05:02 UTC
REVIEW: https://review.gluster.org/21948 ([WIP] rpc: use address-family option from vol file) posted (#3) for review on master by Milind Changire

Comment 3 Worker Ant 2019-01-22 13:48:09 UTC
REVIEW: https://review.gluster.org/21948 (rpc: use address-family option from vol file) merged (#16) on master by Amar Tumballi

Comment 4 Shyamsundar 2019-03-25 16:31:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 5 Amgad 2019-03-27 19:40:21 UTC
would the fix be ported to 5.x stream?


Note You need to log in before you can comment on or make changes to this bug.