Bug 1636037 - Observed MDS failover and events in logs while dumping cache
Summary: Observed MDS failover and events in logs while dumping cache
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: z1
: 3.2
Assignee: Venky Shankar
QA Contact: Shreekar
Erin Donnelly
URL:
Whiteboard:
: 1622243 (view as bug list)
Depends On:
Blocks: 1629656
TreeView+ depends on / blocked
 
Reported: 2018-10-04 10:16 UTC by Ramakrishnan Periyasamy
Modified: 2019-03-07 15:51 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-12.2.8-64.el7cp Ubuntu: ceph_12.2.8-49redhat1
Doc Type: Bug Fix
Doc Text:
.The Ceph MDS no longer allows dumping of cache larger than 1 GB Previously, if you attempted to dump a Ceph Metadata Server (MDS) cache with a size of around 1 GB or larger, the MDS could terminate unexpectedly. With this update, MDS no longer allows dumping of cache that size so the MDS no longer terminates in the described situation.
Clone Of:
Environment:
Last Closed: 2019-03-07 15:50:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0475 None None None 2019-03-07 15:51:06 UTC
Ceph Project Bug Tracker 37608 None None None 2019-01-04 20:01:23 UTC

Description Ramakrishnan Periyasamy 2018-10-04 10:16:17 UTC
Description of problem:
Observed MDS failover when dumping cache using admin-daemon command.

command used: "ceph --admin-daemon ceph-mds.magna083.asok dump cache"

Command was hung for sometime and observed failover in cluster status. Command not exited.

Log: faildover mds log available in magna002 path "/home/rperiyas/fs_4thoct"

Version-Release number of selected component (if applicable):
ceph version 12.2.5-42.el7cp

How reproducible:
1/1

Steps to Reproduce:
1. Configured FS with 2 active and 1 standby
2. Mounted fuse and kernel and started smalfile and crefi IO on different dir
3. During IO's try to dump the cache using admin-daemon command.

Actual results:
MDS failover and dump cache command hung

Expected results:
There should not be a failover

Additional info:
When tried to perform the same active in another MDS, there was no failover of MDS and observed dump cache command output.

Comment 16 Patrick Donnelly 2019-01-04 20:30:58 UTC
*** Bug 1622243 has been marked as a duplicate of this bug. ***

Comment 27 errata-xmlrpc 2019-03-07 15:50:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0475


Note You need to log in before you can comment on or make changes to this bug.