Bug 1636271 - LSI mpt3sas driver not in kernel
Summary: LSI mpt3sas driver not in kernel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: aarch64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException RejectedBlocker
Depends On:
Blocks: ARMTracker F29FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-10-04 22:24 UTC by ed
Modified: 2018-10-30 17:28 UTC (History)
19 users (show)

Fixed In Version: kernel-4.18.14-300.fc29 kernel-4.18.16-300.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:03:59 UTC


Attachments (Terms of Use)

Description ed 2018-10-04 22:24:36 UTC
Description of problem:LSI mpt3sas driver not in kernel 


Version-Release number of selected component (if applicable): 20180923 build 


How reproducible:


Steps to Reproduce:
1.Boot F29
2.lsmod | grep -i mpt3sas
3.modprobe mpt3sas 

Actual results:driver not found and not available 


Expected results:driver available at boot 


Additional info:

Comment 1 Peter Robinson 2018-10-05 12:41:10 UTC
Pushed to F-29 and rawhide, will be in the next build.

Comment 2 Fedora Update System 2018-10-16 18:40:12 UTC
kernel-4.18.14-300.fc29 kernel-headers-4.18.14-300.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-731c2e5ced

Comment 3 Fedora Blocker Bugs Application 2018-10-22 07:28:30 UTC
Proposed as a Blocker for 29-final by Fedora user pbrobinson using the blocker tracking app because:

 mpt3sas storage controller on a number of new aarch64 SBSA platforms and aarch64 servers (SBSA) is a aarch64 blocking reference platform

Comment 4 Fedora Update System 2018-10-22 08:36:12 UTC
kernel-4.18.16-300.fc29 kernel-headers-4.18.16-300.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-dbea673f8a

Comment 5 František Zatloukal 2018-10-22 16:28:24 UTC
Discussed during the 2018-10-22 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made:

"We find this bug worthy of AcceptedFreezeException status as the fix is already available and we can't find specifics regarding if the mpt3sas driver has been included in Fedora before or if it is a new addition."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-10-22/f29-blocker-review.2018-10-22-16.00.log.txt

Comment 6 Fedora Update System 2018-10-22 19:23:32 UTC
kernel-4.18.16-300.fc29, kernel-headers-4.18.16-300.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-dbea673f8a

Comment 7 Fedora Update System 2018-10-23 15:03:59 UTC
kernel-4.18.16-300.fc29, kernel-headers-4.18.16-300.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-10-30 17:28:36 UTC
kernel-4.18.14-300.fc29, kernel-headers-4.18.14-300.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.