Bug 1636480 - dnf-automatic timer files: Incorrect dependency WantedBy=basic.target causing ordering cycle for systemd
Summary: dnf-automatic timer files: Incorrect dependency WantedBy=basic.target causing...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Blaha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1640181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-05 13:45 UTC by Christian Stadelmann
Modified: 2018-12-05 02:33 UTC (History)
9 users (show)

Fixed In Version: dnf-4.0.9-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-12-05 02:33:43 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Stadelmann 2018-10-05 13:45:45 UTC
Description of problem:
Systemd complains about broken configuration of timers installed with dnf-automatic.

Version-Release number of selected component (if applicable):
dnf-automatic-3.6.1-1.fc29.noarch

How reproducible:
always

Steps to Reproduce:
1. enable dnf-automatic-download.timer
2. reboot
3. take a look at syslog

Actual results:
systemd[1]: basic.target: Found ordering cycle on dnf-automatic-download.timer/start
systemd[1]: basic.target: Found dependency on network-online.target/start
systemd[1]: basic.target: Found dependency on network.target/start
systemd[1]: basic.target: Found dependency on network-pre.target/start
systemd[1]: basic.target: Found dependency on firewalld.service/start
systemd[1]: basic.target: Found dependency on basic.target/start
systemd[1]: basic.target: Job dnf-automatic-download.timer/start deleted to break ordering cycle starting with basic.target/start

Expected results:
No error reports from systemd.

Comment 1 Marek Blaha 2018-10-23 07:11:16 UTC
*** Bug 1640181 has been marked as a duplicate of this bug. ***

Comment 2 Marek Blaha 2018-10-23 08:22:01 UTC
PR https://github.com/rpm-software-management/dnf/pull/1247 fixes this issue.

Comment 3 Fedora Update System 2018-11-22 18:57:02 UTC
libdnf-0.22.3-1.fc29 dnf-4.0.9-1.fc29 dnf-plugins-core-4.0.2-1.fc29 dnf-plugins-extras-4.0.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-17cbc3c616

Comment 4 Fedora Update System 2018-11-23 02:56:35 UTC
dnf-4.0.9-1.fc29, dnf-plugins-core-4.0.2-1.fc29, dnf-plugins-extras-4.0.0-1.fc29, libdnf-0.22.3-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-17cbc3c616

Comment 5 Fedora Update System 2018-12-05 02:33:43 UTC
dnf-4.0.9-1.fc29, dnf-plugins-core-4.0.2-1.fc29, dnf-plugins-extras-4.0.0-1.fc29, libdnf-0.22.3-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.