Bug 1636511 - update Google Noto to 2017-09-19 release
Summary: update Google Noto to 2017-09-19 release
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: google-noto-fonts
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-05 15:00 UTC by Jens Petersen
Modified: 2018-12-13 02:16 UTC (History)
9 users (show)

Fixed In Version: google-noto-fonts-20170919-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-13 02:16:00 UTC


Attachments (Terms of Use)
20161022 - good (2.55 KB, image/png)
2018-12-09 22:38 UTC, Nerijus Baliūnas
no flags Details
20170919 - bad (2.25 KB, image/png)
2018-12-09 22:38 UTC, Nerijus Baliūnas
no flags Details
working before upgrade (545 bytes, image/png)
2018-12-11 19:52 UTC, John Smith
no flags Details
broken after upgrade (733 bytes, image/png)
2018-12-11 19:53 UTC, John Smith
no flags Details

Description Jens Petersen 2018-10-05 15:00:00 UTC
Description of problem:
I think we should update F28-F29 from the current 20161022 snapshot to
the latest stable 2017-09-19 release.
https://github.com/googlei18n/noto-fonts/releases/tag/v2017-09-19-phase3-second

Comment 1 Fedora Update System 2018-12-07 11:25:55 UTC
google-noto-fonts-20170919-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a23128d01b

Comment 2 Nerijus Baliūnas 2018-12-09 22:37:13 UTC
After the update a few symbols are rendered incorrectly. For example, Š is rendered as š, ž as some other symbol. I will attach example. Reverting to 20161022 makes the problem disappear.

Comment 3 Nerijus Baliūnas 2018-12-09 22:38:13 UTC
Created attachment 1512919 [details]
20161022 - good

Comment 4 Nerijus Baliūnas 2018-12-09 22:38:35 UTC
Created attachment 1512920 [details]
20170919 - bad

Comment 5 Akira TAGOH 2018-12-10 04:48:43 UTC
Can you try it on rawhide and let me know if that still happens there?

Comment 6 Nerijus Baliūnas 2018-12-10 12:25:39 UTC
Seems OK on rawhide. BTW, the link to URL where the problem is visible and screenshots are taken - https://www.miestai.net/forumas/forum/kitos-diskusijos/visuomen%C4%97-ir-%C5%ABkis/17938-xii-seimas-ir-xvii-vyriausyb%C4%97-po-2016-rinkim%C5%B3?p=1688026#post1688026

Comment 7 Akira TAGOH 2018-12-11 11:26:40 UTC
Assuming that you saw this issue on your browser. did you try to restart your browser after upgrading the google-noto-fonts packages?

Comment 8 Nerijus Baliūnas 2018-12-11 15:06:57 UTC
As reverting (dnf downgrade google-noto-sans-fonts) made text OK even in a running browser session, I did not try to restart browser. Tried now, and it's OK, text is rendered correctly after restart.

Comment 9 John Smith 2018-12-11 19:52:42 UTC
Created attachment 1513502 [details]
working before upgrade

Comment 10 John Smith 2018-12-11 19:53:02 UTC
Created attachment 1513503 [details]
broken after upgrade

Comment 11 John Smith 2018-12-11 19:54:32 UTC
testing in gnome terminal ^

Comment 12 Jens Petersen 2018-12-12 02:27:24 UTC
(In reply to Nerijus Baliūnas from comment #6)
> https://www.miestai.net/forumas/forum/kitos-diskusijos/visuomen%C4%97-ir-
> %C5%ABkis/17938-xii-seimas-ir-xvii-vyriausyb%C4%97-po-2016-
> rinkim%C5%B3?p=1688026#post1688026

Yes renders fine for me with google-noto-sans-fonts-20170919-2.fc29.

I think it is a known issue that live updating fonts (with significant changes) may cause text rendering corruption particularly in browsers (maybe something could be done in FreeType(?) to address this, but surely non-trivial).  This type of problem is a reason that gnome-software and Silvertree, etc require reboots for updates.

Comment 13 Akira TAGOH 2018-12-12 04:51:28 UTC
Exactly. this is a known issue and this happens because fonts are mmap'ed to open. if fonts has drastic changes, the location where tables points to are also changed. so unexpected behavior comes.

my bad that I didn't add a flag to suggest logout. updated on bodhi that way.

Comment 14 Fedora Update System 2018-12-13 02:16:00 UTC
google-noto-fonts-20170919-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.