Bug 1636523 - [RFE] Boost::ASIO "Beast" HTTP front end tech preview
Summary: [RFE] Boost::ASIO "Beast" HTTP front end tech preview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.1
Hardware: All
OS: All
medium
medium
Target Milestone: rc
: 3.2
Assignee: Casey Bodley
QA Contact: vidushi
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1629656
TreeView+ depends on / blocked
 
Reported: 2018-10-05 15:17 UTC by Matt Benjamin (redhat)
Modified: 2019-01-03 19:02 UTC (History)
7 users (show)

Fixed In Version: RHEL: ceph-12.2.8-3.el7cp Ubuntu: ceph_12.2.8-3redhat1
Doc Type: Technology Preview
Doc Text:
.The Beast HTTP front end This update adds a new Ceph Object Gateway HTTP front end called Beast as a Technology Preview. The Beast front end uses the Boost.Beast library for HTTP parsing and the Boost.Asio library for asynchronous I/O.
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:15 UTC

Description Matt Benjamin (redhat) 2018-10-05 15:17:04 UTC
Description of problem:
Tech preview support for new RGW "Beast" HTTP front end based on Boost::ASIO, which has existed in upstream since 2016.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 9 errata-xmlrpc 2019-01-03 19:02:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.