Bug 16370 - Missing symlinks in gd package
Summary: Missing symlinks in gd package
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gd (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-16 16:15 UTC by Mike McHenry
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 16:15:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McHenry 2000-08-16 16:15:05 UTC
I have noticed that the gd-1.8 package is missing compatibility symlinks 
for the following:

/usr/lib/libgd.so
/usr/lib/libgd.so.1

The fix is simple, patch gd.spec with the following...

--- /usr/src/redhat/SPECS/gd.spec       Wed Aug  2 15:08:17 2000
+++ /tmp/gd.spec        Wed Aug 16 11:13:09 2000
@@ -8,6 +8,7 @@
 Group: System Environment/Libraries
 BuildRoot: %{_tmppath}/%{name}-root
 Prereq: /sbin/ldconfig
+Provides: libgd.so libgd.so.1
 BuildPrereq: libjpeg-devel, libpng-devel, zlib-devel
 Requires: libjpeg, libpng, zlib
 %define shlibver %(echo %{version} | cut -f-2 -d.)
@@ -62,6 +63,7 @@
        INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
 install -m 755 libgd.so.%{version} $RPM_BUILD_ROOT%{_libdir}/
 ln -s libgd.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgd.so
+ln -s libgd.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgd.so.1
 
 %clean
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
@@ -73,7 +75,7 @@
 %files
 %defattr(-,root,root)
 %doc readme.txt index.html
-%{_libdir}/*.so.*.*
+%{_libdir}/*.so*
 
 %files progs
 %defattr(-,root,root)

Comment 1 Nalin Dahyabhai 2000-08-16 18:42:05 UTC
The .so symlink is in gd-devel, and a .so.1 would be a bad idea because gd 1.8
is not binary-compatible with 1.3 (it uses PNG and not GIF).


Note You need to log in before you can comment on or make changes to this bug.