Bug 163710 - unable to rebuild evolution package - bad spec file logic
unable to rebuild evolution package - bad spec file logic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-20 11:57 EDT by Eugene Kanter
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.2-16.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 11:33:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2005-07-20 11:57:25 EDT
evolution-2.0.2-16.src.rpm

Description of problem:

evolution has an implicit build dependency on the mozilla package which version
is listed in %define mozilla_build_version x.x.x. However down in BuildRequies
it says

BuildRequires: mozilla-nspr-devel >= 37:%{mozilla_build_version}
BuildRequires: mozilla-nss-devel  >= 37:%{mozilla_build_version}

This means that if mozilla is updated to a next version evolution build will
start but then fail because of 

if [ ! -f /usr/include/mozilla-%{mozilla_build_version}/nspr/nspr.h ]; then
  echo "Unable to find suitable version of mozilla nss to use!"
  exit 1

The spec file must be made flexible enough to avoid the conflict.
Comment 1 Andy Shevchenko 2005-09-23 04:34:03 EDT
2.0.2-16.3 has included that definition.

Dave, why do you not close this bug?
Comment 2 Bastien Nocera 2006-08-14 11:33:40 EDT
Closing as per last comment. Thanks Andy for the notice.

Note You need to log in before you can comment on or make changes to this bug.