Bug 163711 - dhcdbd startup issues
dhcdbd startup issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcdbd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
: 162857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-20 11:59 EDT by Colin Walters
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 20:05:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2005-07-20 11:59:57 EDT
Description of problem:
There's two issues with the current dhcdbd startup priority (11).

1) It links to libdbus which is in /usr/bin; since 11 is before 25, we're not
   guaranteeed /usr is mounted
2) It's long before the startup of messagebus (97), so dhcdbd cannot get on the
   system bus.

Version-Release number of selected component (if applicable):
dhcdbd-1.6-1

This is problematic though, because NetworkManager is at 98, so there isn't
really a place to put dhcdbd.

One possibility is to move messagebus far earlier; that gives us alot of
numerical room so to speak.  Or maybe we drop everything and finish
SystemServices...
Comment 1 Jason Vas Dias 2005-07-20 13:02:50 EDT
*** Bug 162857 has been marked as a duplicate of this bug. ***
Comment 2 Jason Vas Dias 2005-07-20 13:07:53 EDT
The recommended configuration for dhcdbd at the moment is NOT to start it
from the initscript, but to let NetworkManager start it (the dhcdbd.spec
file does NOT do a 'chkconfig --add'), and if dhcdbd is not running,
NetworkManager starts it up.

I'll resolve this issue next week with dhcdbd-1.7, at the same time as 
resolving the issue of whether dhcdbd should auto-start on the session
bus and authentication issues.
Comment 3 Colin Walters 2005-07-20 13:14:04 EDT
I'm confused why dhcdbd has an init script at all if it's not intended to be run
by the init system.  In fact if this is the recommended usage why is it even a
separate package from NetworkManager?

Having NetworkManager execute it currently conflicts with the Fedora SELinux
policy for it; I've added dwalsh to the CC here.  If having NetworkManager exec
dhcdbd is the route chosen then we need to get policy updated to do a domain
transition.
Comment 4 Daniel Walsh 2005-07-20 13:46:52 EDT
domain_auto_trans(NetworkManager_t, dhcpc_exec_t, dhcpc_t)
Is already in there.
Comment 5 Jason Vas Dias 2005-07-20 14:01:01 EDT
RE: Comment #3:
  dhcdbd is intended to be a general-purpose program for controlling dhclient,
  and providing access to dhcp options and notifications of dhcp option change
  to any subscribing application, not just NetworkManager - hence the initscript.
  Yes, I know there is a problem with the chkconfig startup order number -
  As I said earlier, I'll be fixing that in the next release next week, along
  with the authentication issues . 
  The SELinux policy is working correctly for it.

  
Comment 6 Jason Vas Dias 2005-07-27 15:47:57 EDT
This is now fixed with dhcdbd-1.7, now in Rawhide and on external CVS.
The initscript now has 'chkconfig: 345 98 02', the same as NetworkManager,
and will start after the messagebus has started.
The system.d/dhcdbd.conf policy configuration now disallows any user other
than root to send to dhcdbd.
Comment 7 Florian La Roche 2005-07-31 06:35:06 EDT
Might go into a new bugzilla:

/etc/init.d/dhcdbd: line 14: /etc/sysconfig/network: No such file or directory
Comment 8 Jason Vas Dias 2005-08-12 18:10:27 EDT
RE: Comment #7 This is now fixed with dhcdbd-1.8.
    
Comment 9 Erik Jacobson 2005-08-16 16:58:47 EDT
I saw comment #7 during initial install of FC ia64 development.  But dhcdbd in 
development for ia64 hasn't bumped to dhcdbd-1.8 yet.  ia64 is at
dhcdbd-1.7-1.  Adding myself to the cclist.
Comment 10 Jason Vas Dias 2005-08-17 11:29:36 EDT
RE: Comment #9: sorry about that. dhcdbd-1.8 is now in rawhide / development.

Note You need to log in before you can comment on or make changes to this bug.