Bug 1637171 - %postun scriptlet failure in bind-export-libs
Summary: %postun scriptlet failure in bind-export-libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1669814 1684786 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-08 20:08 UTC by Christian Stadelmann
Modified: 2019-09-14 01:54 UTC (History)
13 users (show)

Fixed In Version: 9.11.4-11.P2 bind-9.11.8-1.fc30 bind-9.11.10-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-22 01:03:58 UTC
Type: Bug


Attachments (Terms of Use)
Output of #dnf reinstall bind-export-libs (1.64 KB, text/plain)
2018-10-08 20:08 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2018-10-08 20:08:36 UTC
Created attachment 1491775 [details]
Output of #dnf reinstall bind-export-libs

Version-Release number of selected component (if applicable):
bind-export-libs-32:9.11.4-10.P2.fc29.x86_64

How reproducible:
always

Steps to Reproduce:
1. reinstall or upgrade to bind-export-libs 32:9.11.4-11.P2
2. watch stdout

Actual results:
Error message:
> /sbin/ldconfig: relative path `1' used to build cache
warning: %postun(bind-export-libs-32:9.11.4-10.P2.fc29.x86_64) scriptlet failed, exit status 1

Expected results:
No scriptlet failure

Comment 1 Petr Menšík 2018-10-10 10:20:05 UTC
This bug was fixed in rawhide by Igor Gnatenko, thank you!

Comment 2 Dominik 'Rathann' Mierzejewski 2018-11-21 00:03:11 UTC
With dnf remove bind-export-libs, I can see:

  Running scriptlet: bind-export-libs-32:9.11.4-10.P2.fc29.x86_64                                                   8/8 
/sbin/ldconfig: relative path `0' used to build cache
warning: %postun(bind-export-libs-32:9.11.4-10.P2.fc29.x86_64) scriptlet failed, exit status 1

Is this the same bug? Are you going to backport the fix to F29?

Comment 3 Petr Menšík 2018-11-21 11:04:50 UTC
Yes, I am going to backport it. It is the same bug.

Comment 4 Petr Menšík 2019-01-28 11:39:24 UTC
*** Bug 1669814 has been marked as a duplicate of this bug. ***

Comment 5 Petr Menšík 2019-03-19 11:25:12 UTC
*** Bug 1684786 has been marked as a duplicate of this bug. ***

Comment 6 Zbigniew Jędrzejewski-Szmek 2019-04-09 11:30:14 UTC
Can we please get this resolved? This is quite visible during upgrades.

Comment 7 Fedora Update System 2019-07-17 18:42:25 UTC
FEDORA-2019-b6f0495f51 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b6f0495f51

Comment 8 Fedora Update System 2019-07-17 18:45:56 UTC
FEDORA-2019-f72801c260 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f72801c260

Comment 9 Fedora Update System 2019-07-18 00:42:58 UTC
bind-9.11.8-1.fc30, bind-dyndb-ldap-11.1-17.fc30, dhcp-4.3.6-35.fc30, dnsperf-2.3.0-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f72801c260

Comment 10 Fedora Update System 2019-07-18 03:36:01 UTC
bind-9.11.8-1.fc29, bind-dyndb-ldap-11.1-17.fc29, dhcp-4.3.6-32.fc29, dnsperf-2.3.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b6f0495f51

Comment 11 Fedora Update System 2019-07-22 01:03:58 UTC
bind-9.11.8-1.fc30, bind-dyndb-ldap-11.1-17.fc30, dhcp-4.3.6-35.fc30, dnsperf-2.3.0-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-08-28 21:25:09 UTC
FEDORA-2019-d04f66e595 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d04f66e595

Comment 13 Fedora Update System 2019-08-30 00:25:40 UTC
bind-9.11.10-1.fc29, bind-dyndb-ldap-11.1-19.fc29, dhcp-4.3.6-34.fc29, dnsperf-2.3.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d04f66e595

Comment 14 Fedora Update System 2019-09-14 01:54:07 UTC
bind-9.11.10-1.fc29, bind-dyndb-ldap-11.1-19.fc29, dhcp-4.3.6-34.fc29, dnsperf-2.3.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.