Bug 1637185 - [RHV] ISO provisioning fails with undefined SDK method
Summary: [RHV] ISO provisioning fails with undefined SDK method
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.5
Assignee: Boriso
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On: 1613326
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-08 20:59 UTC by Satoe Imaishi
Modified: 2018-11-05 14:00 UTC (History)
11 users (show)

Fixed In Version: 5.9.5.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1613326
Environment:
Last Closed: 2018-11-05 13:59:40 UTC
Category: ---
Cloudforms Team: RHEVM


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:3466 None None None 2018-11-05 14:00:11 UTC

Comment 2 Boriso 2018-10-11 13:23:26 UTC
This PR is also required:
https://github.com/ManageIQ/manageiq-providers-ovirt/pull/298

Comment 3 CFME Bot 2018-10-11 14:29:08 UTC
New commits detected on ManageIQ/manageiq-providers-ovirt/gaprindashvili:

https://github.com/ManageIQ/manageiq-providers-ovirt/commit/dadbea59d0bf5cd473051548ddda12a4195a695e
commit dadbea59d0bf5cd473051548ddda12a4195a695e
Author:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
AuthorDate: Mon Oct  8 10:13:46 2018 -0400
Commit:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
CommitDate: Mon Oct  8 10:13:46 2018 -0400

    Merge pull request #296 from borod108/bugs/1613326iso_prov

    Fix ISO provisioning with kickstart

    (cherry picked from commit 9d27961b57a542a3259984fdd436d0a25c187435)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1637185

 app/models/manageiq/providers/redhat/infra_manager/ovirt_services/strategies/v4.rb | 10 +
 spec/models/manageiq/providers/redhat/infra_manager/provision/configuration_spec.rb | 39 +-
 2 files changed, 44 insertions(+), 5 deletions(-)


https://github.com/ManageIQ/manageiq-providers-ovirt/commit/cc975a02f4e985772f13d8db24000fd797f0fe8b
commit cc975a02f4e985772f13d8db24000fd797f0fe8b
Author:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
AuthorDate: Wed Oct 10 10:42:36 2018 -0400
Commit:     Piotr Kliczewski <piotr.kliczewski@gmail.com>
CommitDate: Wed Oct 10 10:42:36 2018 -0400

    Merge pull request #298 from borod108/bugs/1613326iso_prov_2

    Fix attach_floppy to pass "floppy" type

    (cherry picked from commit db724df0af9fe3e9dd8fbb136807c2967cbc3cbd)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1637185

 app/models/manageiq/providers/redhat/infra_manager/ovirt_services/strategies/v4.rb | 2 +-
 spec/models/manageiq/providers/redhat/infra_manager/provision/configuration_spec.rb | 1 +
 2 files changed, 2 insertions(+), 1 deletion(-)

Comment 4 Jan Zmeskal 2018-10-17 11:17:45 UTC
So I tried to verify that this bug has been fixed. All the logs and other materials I refer to here can be found in attached archive called "Verification materials". So, firstly, my setup:
- I tried to provision a RHEL7.5 server ISO image.
- I modified this image in two ways: a) In the root of directory structure, I put file called ks.cfg. You can find its contents in attached file ks.cfg.b) I added "inst.ks=cdrom" to all append lines in isolinux/isolinux.cfg.
- For provisioning, I used customization template that can be found in customization_template.txt. This KS script was generated by anaconda during my previous manual installation of RHEL7.5 and I also verified its sanity with ksvalidator.
- In Schedule tab I made sure that the VM is not scheduled to power on after provision.

The outcome:
1) The original problem (undefined SDK method) is not present anymore.
2) The ISO provisioning however still does not seem to be working. The provisioning request gets stuck on this:
[EVM] VM [test_vmix65eg] Step [CheckProvisioned] Status [Creating VM] Message [Waiting for provider PowerOff of Vm id: [70], name: [test_vmix65eg]] Current Retry Number [19]
VM is stuck during boot. In the attached screenshot, you can see the error that is thrown there.

Follow-up:
I think we can verify that the original bug does not affect the product anymore. According to e-mail conversation with Boris, Martin, Ilanit and others, it seems that the current problem might actually by located in RHV. However, before I move this to VERIFIED, I think it would be a very good idea to reference the new bug here. Boris, please, do we have one?

Comment 7 errata-xmlrpc 2018-11-05 13:59:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:3466


Note You need to log in before you can comment on or make changes to this bug.