Bug 16372 - read-only pcmcia man pages not cp'd with -f
Summary: read-only pcmcia man pages not cp'd with -f
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-16 16:27 UTC by kenneth_porter
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 17:36:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch for pcmcia-cs-3.1.18/man/Makefile (1.05 KB, patch)
2000-08-16 17:36 UTC, kenneth_porter
no flags Details | Diff

Description kenneth_porter 2000-08-16 16:27:16 UTC
Using kernel24-2.4.0-0.21.src.rpm.

BuildPCMCIA for normal kernel in spec file fails when copying read-only man pages into destination dir previously created by BuildPCMCIA for 
other kernel types.

Need to patch linux/pcmcia-cs-3.1.18/man/Makefile to pass -f flag to cp so mode 444 files can be overwritten.

Failure only apparent when building package as non-root, and is due to repeated re-building with different options (eg. UP vs. SMP kernel).

Comment 1 kenneth_porter 2000-08-16 17:36:29 UTC
Created attachment 2557 [details]
Proposed patch for pcmcia-cs-3.1.18/man/Makefile

Comment 2 Michael K. Johnson 2000-08-16 19:34:29 UTC
Thanks, fixed in current internal source tree.


Note You need to log in before you can comment on or make changes to this bug.