Bug 1637294 - Ansible 2.6.5-2 packaged with ceph-ansible 3.1.4-2 is broken for Ubuntu
Summary: Ansible 2.6.5-2 packaged with ceph-ansible 3.1.4-2 is broken for Ubuntu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Build
Version: 3.2
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 3.2
Assignee: Ken Dreyer (Red Hat)
QA Contact: vidushi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-09 05:03 UTC by vidushi
Modified: 2019-01-03 19:02 UTC (History)
3 users (show)

Fixed In Version: Ubuntu: ceph-ansible_3.2.0~beta5-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:15 UTC

Description vidushi 2018-10-09 05:03:24 UTC
Description of problem:

For the latest Ubuntu repo for CEPH-3.2, the ansible version is 2.6 and the ceph-ansible version is 3.1.4 and is not compatible. 
The ansible-playbook fails at 'generation of ceph configuration file' on Ubuntu.

TASK [ceph-config : generate ceph configuration file: ceph.conf] ************************************************************************************************************
Monday 08 October 2018  16:10:18 +0000 (0:00:00.266)       0:00:30.786 ******** 
fatal: [magna004]: FAILED! => {"changed": false, "msg": "Unsupported parameters for (copy) module: original_basename Supported parameters include: _original_basename, attributes, backup, checksum, content, delimiter, dest, directory_mode, follow, force, group, local_follow, mode, owner, regexp, remote_src, selevel, serole, setype, seuser, src, unsafe_writes, validate"}

 

Version-Release number of selected component (if applicable)
ansible - 2.6.5-2redhat1                             
ceph-ansible 3.1.4-2redhat1
  
How reproducible:
2/2

Steps to Reproduce:
1. 
2.
3.

Actual results:
Ceph-ansible 3.1 is packaged with ansible 2.6+, which is broken.

Expected results:
Ceph-ansible 3.2 should be packaged with ansible 2.6+

Additional info:
On RHEL, however, the ansible(2.6.5-1) and ceph-ansible (3.2.0) are compatible and supported.

Comment 8 Ramakrishnan Periyasamy 2018-10-17 09:17:39 UTC
Moving this bug to verified state. Ubuntu installation works without any issues.

ansible and ceph-ansbile version below.
ubuntu@node066:/usr/share/ceph-ansible$ sudo dpkg -l | grep ansible
ii  ansible                             2.6.5-2redhat1                             all          Ansible IT Automation
ii  ceph-ansible                        3.2.0~beta5-2redhat1                       all          Ansible playbooks for Ceph

Comment 10 errata-xmlrpc 2019-01-03 19:02:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.