Bug 1637418 - Switching keyboard layouts is not working without relogin/reboot
Summary: Switching keyboard layouts is not working without relogin/reboot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-10-09 08:57 UTC by Lukas Brabec
Modified: 2018-10-29 11:13 UTC (History)
18 users (show)

Fixed In Version: gnome-shell-3.30.1-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 18:37:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-shell/issues/691 None None None 2018-10-23 05:39:57 UTC

Description Lukas Brabec 2018-10-09 08:57:02 UTC
Description of problem:
I'm not able to switch keyboard layout from English to different language (both from panel and using shortcut). This happens only when I boot/login into Fedora Workstation that had only one layout set and add another it the session. After relogin or reboot, switching works as expected.


Version-Release number of selected component (if applicable):
gnome-settings-daemon-3.30.1.2-1.fc29.x86_64
gnome-control-center-3.30.1-2.fc29.x86_64
ibus-1.5.19-4.fc29.x86_64
ibus-gtk2-1.5.19-4.fc29.x86_64
ibus-gtk3-1.5.19-4.fc29.x86_64
ibus-hangul-1.5.1-2.fc29.x86_64
ibus-kkc-1.5.22-10.fc29.x86_64
ibus-libpinyin-1.10.0-3.fc29.x86_64
ibus-libs-1.5.19-4.fc29.x86_64
ibus-libzhuyin-1.8.92-3.fc29.x86_64
ibus-m17n-1.3.4-27.fc29.x86_64
ibus-qt-1.3.3-20.fc29.x86_64
ibus-rawcode-1.3.2-13.fc29.x86_64
ibus-setup-1.5.19-4.fc29.noarch
ibus-typing-booster-2.1.2-1.fc29.noarch


Steps to Reproduce:
1. login or boot into system with just one keyboard layout 
2. open Settings -> Region & Language -> Input sources
3. add another keyboard layout
4. try to type language specific characters


Actual results:
Keyboard layout doesn't switch and stays the same (the one you had at on boot/login)

Expected results:
Keyboard layout can be switched from panel or using super+space

Comment 1 Fedora Blocker Bugs Application 2018-10-09 09:02:32 UTC
Proposed as a Blocker for 29-final by Fedora user lbrabec using the blocker tracking app because:

 Proposing this as final blocker, this bug violates final criterion:
Default panel functionality - All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use.

Comment 2 Lukas Ruzicka 2018-10-11 11:48:21 UTC
Yes, I have been able to reproduce the bug. Tried with German version of Fedora and the behaviour is exactly as described.

Comment 3 Geoffrey Marr 2018-10-15 19:15:46 UTC
Discussed during the 2018-10-15 blocker review meeting: [1]

The decision to classify this bug as a "RejectedBlocker" and an "AcceptedFreezeException" was made as, while this was a split vote falling under the "conditional violation" policy, this was decided to be not quite significant enough to block the release. It is bad, though, and we definitely would like a fix if at all possible.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2018-10-15/f29-blocker-review.2018-10-15-16.00.txt

Comment 4 Kamil Páral 2018-10-16 08:07:45 UTC
Correcting a missing field.

Comment 5 sumantro 2018-10-17 00:57:08 UTC
I can still reproduce this bug

Comment 6 Kamil Páral 2018-10-18 11:18:40 UTC
We've found out that "Chinese (Intelligent Pinyin)" is for some reason not affected by this problem. But I can easily reproduce this issue with Russian (Cyrillic letters instead of Latin letters), French (azerty instead of qwerty), German (special letters/symbols on right Alt + letters or numbers) or Czech (qwertz instead of qwerty, special letters instead of numbers).

Comment 7 Alexander Mikhaylenko 2018-10-18 12:46:29 UTC
Chinese (Intelligent Pinyin) is using an input method, while other mentioned layout don't. You can see it in gnome-control-center, it has a cog displayed next to it.

Comment 8 Michael Catanzaro 2018-10-18 18:36:18 UTC
Hm, it's not that switching the layouts is broken. Switching works. It's that the layout you switch *to* is broken. It's maybe more obvious for me because my primary layout is not qwerty. When I switch to Czech, it becomes qwerty (wrong, should be qwertz) when it was not previously qwerty. So it's really messed up. :)

I'd personally request a blocker revote on this since the issue is quite serious: it merits further slipping IMO. This is my personal opinion as a Workstation WG member, not the opinion of the entire WG.

Comment 9 Michael Catanzaro 2018-10-19 00:32:59 UTC
(Daring to repropose this one, as suggested by Kamil.)

Comment 10 Kamil Páral 2018-10-19 15:42:58 UTC
Fixing fields so that this is re-proposed correctly, see comment 9.

Michael, since this was already rejected once (even though under a split vote), it would be really great if you could rally up more Workstation WG members to cast their vote either on Monday's blocker bug meeting, or here in the bug report, or on the mailing list. We were not united in our opinion and it would help a lot if multiple Workstation WG members spoke up here. Thanks!

Comment 11 Michael Catanzaro 2018-10-19 16:11:26 UTC
We'll discuss on Monday: https://pagure.io/fedora-workstation/issue/81

Comment 12 Julen Landa Alustiza 2018-10-22 08:56:57 UTC
Just retested with michael's info, I change my vote to +1 blocker.

Comment 13 Jens Petersen 2018-10-22 10:59:32 UTC
Easy to reproduce in Live, though as noted restarting desktop fixes it.

(I see it both with GNOME (Wayland) and GNOME on Xorg sessions.)

Comment 14 Michael Catanzaro 2018-10-22 13:22:43 UTC
It's not a control-center bug; I see it changing my setting (/org/gnome/desktop/input-sources sources) just fine. Reassigning to gnome-shell.

Comment 15 Michael Catanzaro 2018-10-22 14:16:20 UTC
(In reply to Michael Catanzaro from comment #11)
> We'll discuss on Monday: https://pagure.io/fedora-workstation/issue/81

We unanimously agreed that this bug should be a release blocker (accepting that it will likely cause another release slip).

Comment 16 Michael Catanzaro 2018-10-22 14:22:14 UTC
(In reply to Michael Catanzaro from comment #15)
> We unanimously agreed that this bug should be a release blocker (accepting
> that it will likely cause another release slip).

Working group vote: (+1: 5, 0: 1, -1: 0)

Comment 17 František Zatloukal 2018-10-22 16:18:42 UTC
Discussed during the 2018-10-22 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made:

"We find this bug to be a violation of the following blocker criteria: "Default panel functionality - All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use." We note that the Workstation WG has voted +1 blocker on this bug."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-10-22/f29-blocker-review.2018-10-22-16.00.log.txt

Comment 18 Carlos Garnacho 2018-10-22 22:37:36 UTC
FTR https://gitlab.gnome.org/GNOME/gnome-shell/issues/691

Comment 19 Jens Petersen 2018-10-23 05:41:38 UTC
(In reply to Carlos Garnacho from comment #18)
> FTR https://gitlab.gnome.org/GNOME/gnome-shell/issues/691

Thanks, Carlos - there are some patches referenced there upstream for this.

Comment 20 Jonas Ådahl 2018-10-23 09:59:44 UTC
Scratch build with Carlos patch: https://koji.fedoraproject.org/koji/taskinfo?taskID=30412485

Comment 22 František Zatloukal 2018-10-23 10:49:14 UTC
Build from https://koji.fedoraproject.org/koji/taskinfo?taskID=30412485 fixes the issue. Jonas, can you submit regular bodhi update? Thanks!

Comment 23 Jens Petersen 2018-10-23 11:08:34 UTC
This build LGTM, thank you!

I tested it lightly on a clean Live image instance (Fedora-Workstation-Live-x86_64-29-20181021.n.0.iso) and was able to add, switch to and use German and Russian keyboard layouts in GNOME (without needing to restart the desktop before using them).
But I would appreciate more people testing this, since it can be slightly tricky.

Comment 24 Kamil Páral 2018-10-23 11:33:52 UTC
(In reply to František Zatloukal from comment #22)
> Build from https://koji.fedoraproject.org/koji/taskinfo?taskID=30412485
> fixes the issue. Jonas, can you submit regular bodhi update? Thanks!

I can also confirm this to be working. Thanks for a quick fix! Please submit a Bodhi update asap, thank you.

Comment 25 Fedora Update System 2018-10-23 12:38:51 UTC
gnome-shell-3.30.1-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3eef9e6d48

Comment 26 Lukas Ruzicka 2018-10-23 14:13:42 UTC
The fix works for me, too. Verified.

Comment 27 Kamil Páral 2018-10-23 14:46:58 UTC
Fix changes from Michael.

Comment 28 Fedora Update System 2018-10-23 17:10:45 UTC
gnome-shell-3.30.1-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3eef9e6d48

Comment 29 Fedora Update System 2018-10-23 18:37:53 UTC
gnome-shell-3.30.1-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.