Bug 1637547 - Kernel 4.18 X230 Docked Blank Screen on Boot
Summary: Kernel 4.18 X230 Docked Blank Screen on Boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-09 13:14 UTC by Theophanis Kontogiannis
Modified: 2018-10-16 12:08 UTC (History)
17 users (show)

Fixed In Version: kernel-4.18.13-200.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-14 23:40:53 UTC


Attachments (Terms of Use)

Description Theophanis Kontogiannis 2018-10-09 13:14:21 UTC
Description of problem:

Using Kernel 4.18* prevents Lenovo X230 (embedded Intel 4000 VGA) to boot when docked.
It gives blank screen when docked.

Version-Release number of selected component (if applicable):


How reproducible:
100% with all currently available 4.18 kernels

Steps to Reproduce:
1. update to Kernel 4.18*
2. Dock the laptop
3. Reboot

Actual results:
Blank Screen

Expected results:
Normal Boot

Additional info:
setting nomodeset / removing rhgb allows the docked laptop to boot into text mode
Undocking the laptop allows it to boot normally.
Downgrading to kernel 4.17 resumes normal boot docked and not docked.

Comment 1 Hans de Goede 2018-10-09 13:35:59 UTC
Can you try adding: "fbcon=nodefer" to the kernel commandline and see if that helps ?

And when you say: "removing rhgb allows the docked laptop to boot into text mode" do you mean that you get the boot messages (and maybe the diskcrypt passwd dialog) in text mode and the the normal graphical login, or does it boot to a text login then (while you normally get a graphical login) ?

Comment 2 Theophanis Kontogiannis 2018-10-09 20:26:17 UTC
Boots in text login.

startx from the cli fails with "No display found" error.

Will try the suggested boot line amendment and revert.

Comment 3 Fedora Update System 2018-10-10 23:32:57 UTC
kernel-tools-4.18.13-200.fc28 kernel-headers-4.18.13-200.fc28 kernel-4.18.13-200.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9f4381d8c4

Comment 4 Fedora Update System 2018-10-10 23:33:55 UTC
kernel-headers-4.18.13-100.fc27 kernel-tools-4.18.13-100.fc27 kernel-4.18.13-100.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2ee3411cb8

Comment 5 Theophanis Kontogiannis 2018-10-11 06:58:56 UTC
Adding "fbcon=nodefer" restores the expected behaviour using 4.18.12-200.fc28.x86_64

Comment 6 Hans de Goede 2018-10-11 08:50:28 UTC
(In reply to Theophanis Kontogiannis from comment #5)
> Adding "fbcon=nodefer" restores the expected behaviour using
> 4.18.12-200.fc28.x86_64

Thanks, then the 4.18.13-200.fc28 should fix this, but the problem will return when you upgrade to F29.

So to be clear, you are booting your laptop into text mode and then starting X with "startx", right ?

I assume you are starting your laptop in UEFI mode ? If you don't know do: "ls /sys/firmware/efi/efivars/" if that returns a bunch of files then you are in UEFI mode.

Comment 7 Theophanis Kontogiannis 2018-10-11 11:01:10 UTC
Will test 4.18.13-200 and revert

Adding "fbcon=nodefer" using 4.18.12-200.fc28.x86_64 was successful, booting straight into in graphical.target

Manual launching startx from cli, was during efforts to debug (was provided as extra info). It is not the case for production. Can be ignored.

[root@tweety-lap ~]# ls /sys/firmware/efi/efivars/
ls: cannot access '/sys/firmware/efi/efivars/': No such file or directory
[root@tweety-lap ~]# ls /sys/firmware/
acpi  dmi  memmap

Comment 8 Hans de Goede 2018-10-11 12:17:19 UTC
Ok, so you are not on UEFI and then fbcon=nodefer should not make a difference.

And double checking I see that the patches to enable fbcon=defer support are not in the F28 kernel at all (as intended) so I'm not sure what you were seeing but fbcon=nodefer should not be helping.

Can you retry 4.18.12-200.fc28.x86_64 without fbcon=nodefer (and without any other special params) ?

I guess you were on an older 4.18.z before and the .12 may just contain a fix which is not related to deferred fbcon takeover at all.

Comment 9 Theophanis Kontogiannis 2018-10-11 18:24:13 UTC
Booting 4.18.12-200.fc28.x86_64 without fbcon=nodefer (and default boot cmd line) allows the laptop to boot in graphical.target when docked.

Previously installed kernels:

kernel-4.18.7-200.fc28
kernel-4.18.10-200.fc28
kernel-4.18.11-200.fc28

Comment 10 Fedora Update System 2018-10-11 22:12:10 UTC
kernel-4.18.13-100.fc27, kernel-headers-4.18.13-100.fc27, kernel-tools-4.18.13-100.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2ee3411cb8

Comment 11 Fedora Update System 2018-10-12 00:23:54 UTC
kernel-4.18.13-200.fc28, kernel-headers-4.18.13-200.fc28, kernel-tools-4.18.13-200.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9f4381d8c4

Comment 12 Hans de Goede 2018-10-12 09:27:51 UTC
(In reply to Theophanis Kontogiannis from comment #9)
> Booting 4.18.12-200.fc28.x86_64 without fbcon=nodefer (and default boot cmd
> line) allows the laptop to boot in graphical.target when docked.

Ok, then this indeed is not related to fbcon=defer support and something else was broken in older 4.18.x kernels which is fixed in 4.18.12. Either way since this is fixed in 4.18.12+, this bug can be closed now :)

Comment 13 Fedora Update System 2018-10-14 23:40:53 UTC
kernel-4.18.13-200.fc28, kernel-headers-4.18.13-200.fc28, kernel-tools-4.18.13-200.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2018-10-16 12:08:55 UTC
kernel-4.18.13-100.fc27, kernel-headers-4.18.13-100.fc27, kernel-tools-4.18.13-100.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.