Bug 1637564 - Customer reports regression of BZ 1441055 with NFS-Ganesha in gluster 3.8.4-54
Summary: Customer reports regression of BZ 1441055 with NFS-Ganesha in gluster 3.8.4-54
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: common-ha
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 3.4.z Batch Update 3
Assignee: Kaleb KEITHLEY
QA Contact: Jilju Joy
URL:
Whiteboard:
: 1641673 (view as bug list)
Depends On:
Blocks: 1649191
TreeView+ depends on / blocked
 
Reported: 2018-10-09 13:40 UTC by Andrew Robinson
Modified: 2019-02-05 11:51 UTC (History)
16 users (show)

Fixed In Version: glusterfs-3.12.2-33
Doc Type: Bug Fix
Doc Text:
Earlier, a race condition between `pcs cluster setup ...` and `systemctl enable pacemaker` sometimes left Pacemaker disabled. As a result, Pacemaker failed to start on one or more nodes after reboot. With this release, the '--enable' option has been added to the `pcs cluster setup ...` command to enable and start Pacemaker automatically after reboot.
Clone Of:
Environment:
Last Closed: 2019-02-04 07:41:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0263 0 None None None 2019-02-04 07:41:38 UTC

Description Andrew Robinson 2018-10-09 13:40:41 UTC
Description of problem: 

Bug 1441055 - pacemaker service is disabled after creating nfs-ganesha cluster. Customer report regression of this BZ when setting up NFS-Ganesha in gluster 3.8.4-54

Version-Release number of selected component (if applicable):

RHGS 3.3.1
gluster 3.8.4-54


How reproducible:

Configure NFS-Ganesha on a gluster cluster on which the pacemaker service has been previously enabled.


Steps to Reproduce:
1. Enable pacemaker on gluster cluster prior to configuring NFS-Ganesha
2. Configure NFS-Ganesha
3. See pacemaker disabled

Actual results:

Pacemaker service disabled


Expected results:

Pacemaker server not disabled


Additional info:

Comment 6 Jiffin 2018-11-22 04:28:57 UTC
*** Bug 1641673 has been marked as a duplicate of this bug. ***

Comment 7 Kaleb KEITHLEY 2018-11-26 15:37:29 UTC
https://code.engineering.redhat.com/gerrit/154376

Since https://bugzilla.redhat.com/show_bug.cgi?id=1641673 has already been closed I am clearing the Needinfo.

Comment 13 Jilju Joy 2018-12-24 08:24:25 UTC
Verified this with below scenarios.
1. Configure ganesha on fresh setup
 1.1. with pacemaker already enabled on all nodes.
 1.2. with pacemaker disabled on all nodes.
 1.3. with pacemaker already enabled only on few nodes.
 
2. Disable existing ganesha cluster.
   Enable ganesha cluster
 2.1. with pacemaker already enabled on all nodes.
 2.2. with pacemaker disabled on all nodes.
 2.3. with pacemaker already enabled only on few nodes.
   2.3.1. Ganesha enable from node where pacemaker is enabled.
   2.3.2. Ganesha enable from node where pacemaker is disabled.

3. Disable pacemaker on existing ganesha nodes --> disable ganesha cluster --> enable ganesha.
4. Disable pacemaker on existing ganesha nodes --> disable ganesha cluster --> enable pacemaker on nodes --> enable ganesha.

Result:
 pacemaker is 'enabled' after setting up ganesha.

Based on the observations, marking this bug as verified.

Comment 15 Srijita Mukherjee 2019-01-20 19:17:38 UTC
The doc text has been updated. Kindly review the technical accuracy.

Comment 17 errata-xmlrpc 2019-02-04 07:41:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0263

Comment 18 Kaleb KEITHLEY 2019-02-05 11:51:18 UTC
updated Doc Text.


Note You need to log in before you can comment on or make changes to this bug.