Bug 1637652 - Glusterd2 is not cleaning itself
Summary: Glusterd2 is not cleaning itself
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-09 16:48 UTC by M. Scherer
Modified: 2019-05-27 15:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-27 15:35:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description M. Scherer 2018-10-09 16:48:14 UTC
I got paged by my old type friend nagios, because builder49 getting out of space:
https://munin.gluster.org/munin/int.rht.gluster.org/builder49.int.rht.gluster.org/df.html

A investigation showed that this come from glusterd2 job creating container in buildah and not cleaning itself. I did remove a few of them with 

  su - jenkins 
  buildah images + a liberal use of buildah rmi


But I can't investigate more cause I am currently on PTO and on my bed.
I would point to this job as a culprit:

https://build.gluster.org/job/glusterd2-containers/

I see nothing to cleanup the container built hence the slow grow.

Comment 1 Nigel Babu 2018-10-16 05:25:38 UTC
My fault! I'll assign this to myself and ensure it's cleaned up.

Comment 2 M. Scherer 2018-10-16 15:27:15 UTC
Also, while looking at it, we maybe should upgrade the base container from time to time, or there is something I overlooked ?

Comment 4 Amar Tumballi 2019-05-27 15:35:48 UTC
Not working actively on glusterd2, and hence marking it as DEFERRED.


Note You need to log in before you can comment on or make changes to this bug.