Bug 1637762 - Rebase kmod-kvdo to use UDS version 6.2.0.
Summary: Rebase kmod-kvdo to use UDS version 6.2.0.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod-kvdo
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Thomas Jaskiewicz
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-10 02:26 UTC by Andy Walsh
Modified: 2019-08-06 13:08 UTC (History)
4 users (show)

Fixed In Version: 6.1.2.16
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:08:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2233 None None None 2019-08-06 13:08:14 UTC

Description Andy Walsh 2018-10-10 02:26:41 UTC
Description of problem:
There have been many improvements to the 6.2.0 version of UDS that can be used for VDO in the RHEL7 releases.  Rebasing to use this will have no visible impact to the user, but will provide many stability improvements with minimal effort.

Version-Release number of selected component (if applicable):
6.1.2.0

Additional info:
UDS 6.2.0.x version is used in a more modern release of VDO that is available on github and Fedora COPR currently.

Comment 5 Thomas Jaskiewicz 2018-10-30 17:59:20 UTC
vdo version 6.1.2.16 uses uds version 6.2.0.

Comment 7 Jakub Krysl 2019-05-31 13:35:03 UTC
Regression testing could not find any issues.
kernel-3.10.0-1048.el7.x86_64
vdo-6.1.2.41-4.el7.x86_64
kmod-kvdo-6.1.2.41-5.el7.x86_64

# modinfo uds
filename:       /lib/modules/3.10.0-1048.el7.x86_64/weak-updates/kmod-kvdo/uds/uds.ko
version:        6.2.0.77
license:        GPL
author:         Red Hat, Inc.
description:    deduplication engine
retpoline:      Y
rhelversion:    7.7
srcversion:     F418316B726FC007E63A8C8
depends:        
vermagic:       3.10.0-1030.el7.x86_64 SMP mod_unload modversions 
signer:         Red Hat Enterprise Linux Driver Update Program (key 3)
sig_key:        BF:57:F3:E8:73:62:BC:72:29:D9:F4:65:32:17:73:DF:D1:F7:7A:80
sig_hashalgo:   sha256

Comment 9 errata-xmlrpc 2019-08-06 13:08:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2233


Note You need to log in before you can comment on or make changes to this bug.